1

I need to configure exim to deliver messages to domain abc.com and send a copy to another server, which is also configured for abc.com.

Something like that:

user@gmail.com sends email to test@abc.com

abc.com mx resolves to 200.200.200.10 ( one of the exim servers )

Message is delivered

Exim receives the message locally AND send a copy to 200.200.200.50 

I tried to setup a smarthost:

        smarthost:
                driver = manualroute
                domains = abc.com
                transport = remote_smtp
                route_data = "200.200.200.50"

It does deliver to the other server but it doesn't save the message locally.

Any ideas of what i can do?

Thanks.

  • Might be possible with a shadow_transport. Leaving a comment rather than an answer since I'm not 100% certain how to implement them. Shadow_transport listed here exim.org/exim-html-current/doc/html/spec_html/ch24.html – EightBitTony Aug 9 '11 at 19:06
  • Also, there's the unseen option for routers - "You can force an address to continue through the routers even if it has been accepted by using the unseen option" – EightBitTony Aug 9 '11 at 19:33
  • @EightBitTony Thank you! The unseen option did the trick. If you answer the question, i can mark it as accepted :) – Fernando Aug 9 '11 at 19:39
  • Answered below, glad I could help. – EightBitTony Aug 9 '11 at 19:45
4

You can use the unseen keyword on routers.

When this option is set true, routing does not cease if the router accepts the address. Instead, a copy of the incoming address is passed to the next router ...

from Generic options for routers.

I think try,

smarthost:
  driver = manualroute
  domains = abc.com
  transport = remote_smtp
  route_data = "200.200.200.50"
  unseen

Before the other routers?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.