Some idiot (one guess as to who) installed a Cisco/Linksys SRW2024P in a 2nd location and forgot to change the IP before doing so. Now it's on a new subnet and I need to control it via console port.

I'm used to controlling Cisco gear through the console port from my Mac using screen or ZTerm and a Tripp Lite (née Keyspan) USB-to-Serial adapter, but have the benefit of being up to my neck in Cisco's blue DB9-to-RJ45 console cables. This Cisco/Linksys switch has a DB-9 male console port and I dug out a female-to-female DB9 serial cable, but I have no idea whether it's a null modem cable or not and it doesn't seem to work using the official serial port settings for the SRW2024P:

Bits per second: 38400
Data bits: 8
Parity: None
Stop bits: 1
Flow control: None

I must admit that I'm usually lucky and what cables I have tend to work, but not this time. Unfortunately, the former admin ditched the box & cables. So, should I need a null modem cable like the Tripp Lite P450-006 Null Modem Gold Cable DB9F/F - 6ft or something else?

I can get all crazy if I have to, but that's a lot of effort for something I could just buy a cable for, esp. since I'd like to keep the correct cable with this switch from now on. Any other ways to get into this that I'm not thinking of?


I have tried a random serial cable and the aforementioned Tripp Lite null modem cable with my Keyspan USB-to-Serial adapter (both ZTerm and screen), and get nothing, no matter how many times I tap enter/return (okay, I haven't tested all the possibilities there). This is with using the aforementioned serial settings as well as the following (I found both in official documentation):

Bits per second: 115200
Data bits: 8 
Parity: none 
Stop bits: 1
Flow control: none

By connecting directly to the switch via ethernet and changing my IP to the same subnet as the original IP of the switch I can connect via the web interface, but do not have the password. And, no, it's not the default! So, my only option is serial (to perform a password reset, but that doesn't seem to be working in the slightest.

Any further suggestions would be greatly appreciated!

  • This might be a dumb suggestion, but what about changing the ip (or multihoming it) on your mac to match the subnet setup on the Linksys and then change it then reset everything back? I've had to do this a few times over the years and I totally feel for you trying to get the right console cables to work.
    – MikeAWood
    Aug 10, 2011 at 0:18
  • There's only two possible cables, you need either a null-modem serial cable or a straight-through serial cable. Most Routers/Switches/etc take the null-modem as the manufacturer considered their device to be a "computer" of it's own right. Others took the opposite position, so their wired for DCE and take the "traditional" straight-through cable. In either case a good geek should have one of each laying around. =]
    – Chris S
    Jan 17, 2012 at 13:37

5 Answers 5


This is the pin out of the connector on the switch.

Pin 1 : NC                                  Pin 6 : NC
Pin 2 : RxD                                 Pin 7 : NC
Pin 3 : TxD                                 Pin 8 : NC
Pin 4 : NC                                  Pin 9 : NC
Pin 5 : GND

A null modem cable should work.

  • See my updated question. Any further thoughts on the serial cable front?
    – morgant
    Aug 25, 2011 at 22:40

I have the SRW2024 and had to make a cable also.

My cable is wired 2--2, 3--3, 5--5 between the two female DB9's.

38400-8-N-1, No flow control.


Edit: I agree with Mike above - try just changing the IP on your laptop to be on the same subnet on the switch and plugging it into the switch first. Might just be that simple.

If not... Yes, you need a null modem cable. The fact that the DB-9 connector is male indicates it is a DTE (data terminal equipment, like a terminal, or... your PC). Normal serial cables are meant to go DCE (data communications equipment)-DTE, thus the gender mismatch.

Now, why Linksys would put a DTE port and call it a 'console' port instead of a real console port is another matter... but I don't think simply gender-bending, as you have done, will ever work.

  • Assuming that the OP actually knows what ip address/netmask is configured on the switch...
    – joeqwerty
    Aug 10, 2011 at 0:31
  • I believe I do know the IP, but didn't have a USB-to-Ethernet available at the time for my MacBook Air. As this is at a second location, I'd much prefer to be able to do this remotely via serial so if I screw up the reconfiguration I can recover from it without having to make the trek. That said, wouldn't a DTE-to-DTE serial cable be a null-modem cable?
    – morgant
    Aug 10, 2011 at 3:12
  • I have tried the Tripp Lite null modem cable I linked to to no avail. Connecting via ethernet & on the same subnet lets me connect to the web interface, but I need to reset the password via serial. (See updated question for more info.) Any further thoughts on the serial cable front?
    – morgant
    Aug 25, 2011 at 22:39

Reset switch password

  1. Get hyperterm for windows: https://digitizor.com/install-winxp-hyperterminal-client-on-windows-vista-or-windows-7-free/
  2. Or use PuTTy
  3. The advice is to connect to the console port using terminal emulation parameters (typically 38400, 8, 0, 1, None)
  4. I found out this works better:

Bits per second: 115200 Data bits: 8 Parity: none Stop bits: 1 Flow control: none

  1. Reboot switch (Remove power)
  2. Hold down Ctrl U while rebooting a. Menu will be displayed
  3. Select> [D] Delete file
  4. Type startup-config (be sure that this is the ONLY file that you delete – if you delete other files, you will have to reload the firmware)
  5. Now, you have erased the configuration file and you should be able to reboot and login with the default username and password.

I did not have the ciorect terminal cable lying around...

I used a generic USB to serial comport bought at aliexpress for 2 dollars. And a universal DB9 female to female gender changer (which acts as a ground-to-ground 1-1 2-2 3-3 4-4 5-5 6-6 7-7 8-8 9-9 nullmodem. Which is just what this Linksys POE router SRW224P needs.) No soldering! :)


I managed to access mine with a straight-through female to female DB9 cable and a USB to serial adapter set to 38400-8-N-1, No flow control.

I also needed to hit ENTER/ESC (ONCE) before the "Hit escape" option. It says it will wait 2 seconds, but it doesn't. Don't hit it twice, or it will resume boot normally (unless that's what you want).

Others say using a null-modem cable worked for them. Perhaps different revisions used different pin-outs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .