I am running two virtual 2008 Windows Servers that have been having some reoccurring problems for the past few months. Msiexec.exe seems to run and always freezes at 25% cpu usage and around 12 - 15k memory usage when uninstalling (and perhaps installing) certain applications.

I first noticed this when trying to remove C++ Visual Basic then trying to run a repair utility for it as well... froze at 25%. Tonight I was trying to uninstall Office 2003 from this server and it locked up from the Add / Remove programs method. I then downloaded Microsoft's cleanup utility and on the second step it calls msiexec.exe and it hung at 25% as well!

Here is what I've tried and know - - This is happening on both servers. - I've ran sfc /scannow nothing found. - Ran checkdisk on both servers, nothing found. - Scanned for viruses. - Removed Anti Virus and tried. - Stopped services, msconfig items, and tried booting to a basic config. - msi.dll is at 4.5 (latest version without R2 or W7) - Tried setting the priority for msiexec.exe from task manager.

Any ideas?

  • Please tag your question with the name of the operating system when asking operating system specific questions. Thank You! (edited to add "windows-server-2008")
    – snap
    Aug 10 '11 at 7:29

We had a similar problem with Server 2003 with Terminal Services. MSIEXEC.EXE would consume 25% CPU for an unusually long time during install/uninstall, but if we waited it would complete. Small .MSI packages which should have taken seconds to install were taking 15 or 20 minutes. We found the problem was NTUSER.DAT bloat and registry keys from Hewlett Packard printers. We used the following procedure from http://www.brianmadden.com/forums/t/12621.aspx to resolve the issue:

  1. Delete the following keys:
    • HKLM\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\hewlett-packard
    • HKU\.Default\Software\Hewlett-Packard
  2. Then delete all the user profiles so they will be recreated at next user login without all the bloat.

Hope this might help you.


See if you have any luck with reinstalling the Windows Installer 4.5 Redistributable. Hopefully this doesn't become a chicken and egg deal where you can't install that because the installer doesn't work.

  • I downloaded that installer awhile ago and tried to install it but it said it wasn't supported or necessary on my system. Windows6.0-KB942288-v2-x86.msu is the one I tried (2008 32-bit).
    – Brandon
    Aug 10 '11 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.