my Windows 2003 R2 print server spooler service keeps crashing. upon startup I'll get an error message stating "Unhandled Win32 exception occurred in spoolsv.exe". no matter how many times i try to start the print spooler service manually, it'll stop itself within minutes or seconds. sometimes it won't stop until i try to open "Printers and Faxes". It just keeps sending 7034 Event Errors in the Event Viewer stating "The Print Spooler service terminated unexpectedly".

i've tried running virus and spyware scans, tried running CleanSPL, nothing is working and none of my users can print as all of our printers go through this server.

I cannot open Server Properties in the printer window, and when i try to view Admin Tools>Print Management i get a red X over my server name, and as soon as i open it, it'll kill the spooler service again if i've manually started it.

This server is also used for several SQL servers so a simple reinstall isn't an option right now. the server is running a little low on space, and seems like a defrag could also be done, but i can't imagine these would be causing the problems.

Printing was working just fine for weeks and then this morning it stopped. no new drivers have been installed for at least 2 weeks, and i'm still checking to see if WSUS updated anything last night. Anyone have any thoughts?

  • Have you tried running a process monitor to check what exactly is happening when the spooler crashes? Aug 11 '11 at 8:57

The low disk space could be an issue if the server tries to spool a job and there is not enough space. How low is low space?

There is an issue with the sppoler service addresed by a hotfix. It is related to drivers being copied to clients from the server MS Support Article

Have also seen a similar issue were removing all printers and adding them again resolved constant crashes of the spooler.


seems like the problem must have been a bad driver recently installed. after running CleanSPL it removed all of the printers we had installed (which we couldn't access anyways due to the print spooler dying) and I had to go through and recreate every printer in the system. The problem has not happened again after several days and printers seem to be working now. it took a day to recreate all 25+ printers and redownload the appropriate drivers, but the problem seems to be resolved now.


You might also check to ensure there no stranded spool files within the spooler directory as well. Stray/stranded spool files can also cause difficulties.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.