A user has a set filter, not to show already read mails in outlook. The filter is mandatory for the user. The user also can access the mailbox using his blackberry (the BES is at the mercy of the mobile provider, and it connects to my Exchange using sPOP3)

When the BB phone connects, the emails are automatically marked as "read" which of course means the user will never see them in the Outlook inbox.

The question is how I can prevent this marking as read, so no email is missed in Outlook, without access to the BES (and the provider refuses to make any changes there). A way to mark anything pulled out via POP as unread will also work for me of course. I couldn't find a setting in the BB phone itself to prevent marking everything as read.

Versions: Outlook 2007 / Exchange 2010

UPD: after opening up IMAP the issue is resolved. Thanks to everyone who responded


POP3 is your issue - I'm afraid you can't do much without changes to the access method.

Is it a carrier-managed BES, though? That would seem to me as a bit odd, since BIS is built around just that scenario.

The mobile providers that I've dealt with have always used BIS - which the user should be able to configure to use IMAP or HTTPS API calls, avoiding the POP3 read marking behavior - as well as letting you turn off that antiquated protocol.

  • I have IMAP enabled as well, encrypted of course, but for some reason the BB can't pick it up, and there's no option to manually set up ports – dyasny Aug 10 '11 at 19:52
  • as for BES vs BIS - you might be right there, could be BIS, this is not really my cuppa, and totally out of my control. – dyasny Aug 10 '11 at 19:53
  • orangeil.blackberry.com is the control panel, if that helps any. As for https API calls, you mean opening OWA to the world, or something else? – dyasny Aug 10 '11 at 19:55
  • 1
    If IMAP access wasn't available at the time the user set up the account w/ the carrier's BIS,it would have only had the POP option. I'd say login to the carrier's management interface for that account, delete the mail account and re-add. It should try secure IMAP first, and work its way down. I think you can also force it, but I don't know how to do that off-hand. – Alex Aug 10 '11 at 20:08

If you absolutely can't get away from POP3 you can use this ugly hack:

Make a second mailbox for the user, configure it as an alternate delivery recipient for the user, hide it from the Exchange address list, and use this "clone" mailbox as the POP3 mailbox for the provider to poll.

It's ugly, but it'll do what you need. You'll want to clean out that "clone" mailbox periodically, too.

  • I can get away from POP3 if I must, but I need to know where to :) I've got IMAP set up with TLS and SSL, and the BB can't seem to be able to reach it (maybe it's because of the self signed cert?) – dyasny Aug 10 '11 at 19:57
  • @dyasny: I'd tend to blame the self-signed cert first-- yeah. – Evan Anderson Aug 10 '11 at 19:58
  • right, I'm stuck with it for now, and I'd hate to open an unencrypted port to the world (making the users forget about ftp and move to sftp already cost me several years of my life). Any idea how I can make the phone accept that cert? Or should that be done at the mobile providers' server? – dyasny Aug 10 '11 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.