<UPDATE>/etc/init.d/ doesn't appear to contain any relevant entry (retrieved via ls -A):

abrtd         certmonger  firstboot  irqbalance     mysqld          nscd     portreserve  rpcidmapd   snmpd      vmware-tools
acpid         cgconfig    functions  kdump          netconsole      nslcd    postfix      rpcsvcgssd  snmptrapd  vncserver
atd           cgred       haldaemon  killall        netfs           ntpd     psacct       rsyslog     sshd       webmin
auditd        cpuspeed    halt       lvm2-monitor   network         ntpdate  rdisc        sandbox     sssd       wpa_supplicant
autofs        crond       httpd      mdmonitor      NetworkManager  oddjobd  restorecond  saslauthd   sysstat    ypbind
avahi-daemon  cups        ip6tables  messagebus     nfs             openct   rpcbind      single      tomcat6
bluetooth     dnsmasq     iptables   microcode_ctl  nfslock         pcscd    rpcgssd      smartd      udev-post

The good news is that installation without using Yum is as simple as unpacking the manually-downloaded archive, which contains the directory structure that all the "how-to" guides expect. However, this still doesn't explain why Yum provides a non-functional installation. Since there are probably quite a few people who automatically turn to Yum to get their packages, a more satisfactory answer would be nice, for their sake.</UPDATE>

I'm pretty new to CentOS (and Linux in general) and am trying out a few different servlet containers. I've already got Tomcat installed and capable of running a few example servlets, so I know the basic infrastructure works. I then installed Jetty via Yum (yum install jetty-eclipse), which completed successfully. I then found this guide which explains how to start the service, by executing start.jar in the install directory. Not knowing where Yum installed Jetty, I did a locate start.jar and got no hits. I then tried locate jetty and got the following:


Even assuming that /usr/share/jetty-eclipse/ is the installation directory, all the guides I've seen assume that there is a start.jar file plainly visible somewhere, which is not true in my case. It obviously doesn't make sense for Yum to install a service that cannot run, so what am I missing?

  • Check to see if there is already an init script in /etc/init.d. – quanta Aug 11 '11 at 14:25

It seems to be a bad package. Not only is start.jar missing but also some of the other jetty jars like jetty-jsp, jetty-servlet and even basic documentation. Compare it with the rpm for Fedora; amazing difference.

To save yourself aggravation in future:

  • to list a package's files, run: rpm -ql jetty-eclipse
  • locate queries a database that is periodically refreshed by a cron job running updatedb. You could force the issue by issuing the command yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.