I've installed MS WSUS (SP 2 or 3) on a Windows Server 2008 32-bit server.

I've done some basic configuration, and the only computer it lists under All Computers or Unassigned Computers is our domain controller (seperate to the server WSUS is installed on).

Under Update Services > Options > Computers, "Use the Update Services console" is selected to specify how computers are assigned to groups.

The DC's name is the fully qualified host.domain.name, etc, and I can ping a PC using it's own full host name from the WSUS server.

I've clicked Refresh, and no other PCs appear.

The WSUS service is currently sychronising with the remote MS Update server, and I am unable to change how computers are assigned to groups while it is synching. Is the service synchronisation preventing new computers from being added/detected, perhaps to conserve bandwidth/resources?

How else do I have them detected under Unassigned Computers?


1 Answer 1


The WSUS server doesn't contact the computers, the computers are configured to contact the WSUS server - which is what puts them into the group.

You'll want to set up a group policy which gives the clients a configuration in the Specify Intranet Microsoft Update Service Location setting, pointing the clients to your WSUS server's HTTP address.

  • yep, I've done that, and run gpupdate /force, and wuauclt.exe /resetauthorisation /detectnow, on the client PC.
    – Steve
    Aug 12, 2011 at 6:32
  • I can also open WSUSServerName/selfupdate/wuident.cab from the client PC, so it has connectivity to the WSUS server.
    – Steve
    Aug 12, 2011 at 7:28
  • However, it looks like the group policy is not being rolled out correctly The PC has no WindowsUpdate key under HKLM\Software\Policies\Microsoft\Windows
    – Steve
    Aug 12, 2011 at 7:43
  • The solution was editing the GP for the computer group in the domain, not the "local computer" of the DC. :-P
    – Steve
    Aug 12, 2011 at 8:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .