I'm using DFS to access varios shares on a server using a domain namespace - like \mydomain.local\docs. The DFS shares are not replicated. The shares are located on a DC

After rebooting the host the shares become unavailable from the client machines until they too reboot or restart the dfs client service.

I've seen a similar problem when we had windows 2003 and win xp but the problem seems to be exacerbated with our current setup which is Win2008 and Win7.

The problem is a client one and not a server problem - I think. If I reboot the server and then boot or reboot a workstation it will have immediate access to the share. Any client machine which had previously been connected but which has not yet rebooted is unable to access either a previously mapped drive nor the unc for the dfs share, nor access the underlying unc (so they can't access X:, \dfsspace.local\xdrive nor \server\xdrive)

The error varies but it can be the old 'the system can't find the specified route' or it can also be an error which states that the driver is no longer valid. Trying to access from either explorer or from command line produces the same result - so its not an explorer problem.

If you just leave the pc, then the access to the shares will start working after half an hour or so, though not always. Yesterday I was upgrading a NAS and rebooted the server to update it while waiting on Nas copies to complete. This morning my own Win7 still could not access the shares some 12 hours later. Other users who had come in this morning and booted had no problems. A quick reboot fixed the problem with mine but this doesn't make any sense.

It appears like some sort of a dfs cache problem but I'm not sure and it makes little sense.

On machines with offline files enabled the problem is generally worse, they will see the drives as being available but empty. After some time the shares will suddenly show their correct contents.

I've tried trawling the ms docs, technet, google and haven't found anything very relevant - so this is either something so obvious and dumb that I'm just missing it or we have an extremely esoteric problem... I suspect the former.

Can anyone shed any light on my woes?



It does sound like a DFS cache problem as the default link referral cache time is 1800 seconds, which is 30 minutes. It's curious why it's failing after a reboot. I would suggest running dfsutil /PktInfo from a client (you'll need to get dfsutil from the W2K3 admin tools pack) or get it with the RSAT for Windows 7 and see if that gives you any clue as to what's happening.

  • Just noticed that I have dfsutil installed on my own machine already. The output isn't exactly intended for everyday use, so I'm not sure what I'm looking for, but its a starting point, thanks. – Ian Murphy Aug 12 '11 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.