i setup apache on amazon ec2 instance with ubuntu

i using the document root set to the /mnt/www/domain.com/htdocs

i get these errors on the apache logs when any file is accessed.

[Fri Aug 12 12:26:46 2011] [error] [client xxxxxxx] File does not exist: /mnt
[Fri Aug 12 12:26:46 2011] [error] [client xxxxxxx] File does not exist: /mnt
[Fri Aug 12 12:26:47 2011] [error] [client xxxxxxx] File does not exist: /mnt

fstab file:
/dev/xvda2      /mnt    auto    defaults,nobootwait,comment=cloudconfig 0       2
/dev/xvda3      none    swap    sw,comment=cloudconfig  0       0

<VirtualHost *:80>
        ServerAdmin [email protected]
        ServerName  www.domain.com
        ServerAlias domain.com

        # Indexes + Directory Root.
        DirectoryIndex index.php
        DocumentRoot /mnt/www/www.domain.com/htdocs/

        # CGI Directory
        ScriptAlias /cgi-bin/ /mnt/www/www.domain.com/cgi-bin/
        <Location /cgi-bin>
                Options +ExecCGI

        # Logfiles
        ErrorLog  /mnt/www/www.domain.com/logs/error.log
        CustomLog /mnt/www/www.domain.com/logs/access.log combined

what could be the issue?

After further research

I fixed it myself, i had earlier enabled chroot module in apache config and after diabling it worked..

  • Does /mnt actually exist? And have you checked permissions if it does? Aug 12, 2011 at 12:33
  • it exists.. drwxr-xr-x 3 root root 4.0K 2011-08-12 12:18 mnt
    – krisdigitx
    Aug 12, 2011 at 12:34
  • Please post your Apache configuration file?
    – quanta
    Aug 12, 2011 at 12:45

1 Answer 1


Based on your update, you might want to reenable chroot and update the VirtualHost entries so that they refer to the directory structure of the chroot environment.

  • cool will try...
    – krisdigitx
    Aug 13, 2011 at 15:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .