We are using System Center Virtual Machine Manager 2008 R2 trying to allow creation of VMs using templates. The two computers involved are HQ-VMM1 (Server 2008 R2 Enterprise SP1, running SCVMM) and HQ-VM2 (Server 2008 R2 Datacenter SP1, running the Hyper-V role).

Whenever we create a VM from a template using either from SCVMM Admin Console or the Self-Service Portal, the job stops on "Install VM Components" and after a few minutes we get the error:

Error (2927)
A Hardware Management error has occurred trying to contact server HQ-VM2.domain.local. (Unknown error (0x80338029))

Recommended Action
Check that WinRM is installed and running on server HQ-VM2.domain.local. For more information use the command "winrm helpmsg hresult".

When I check the Hyper-V console on HQ-VM2, the virtual machine has been created but it has not been set up at all, and I cannot start it from the self-service portal (I can start it directly from the Hyper-V console, though).

Things I have tried:

  • I've found this article describing how to troubleshoot WinRM. It was not previously running on HQ-VM2, but running winrm quickconfig fixed that. I also made sure it was running on HQ-VMM1. I opened a command prompt on HQ-VMM1 and ran winrm id -r:hq-vm2 to make sure the WinRM service was accessible, and I received an IdentifyResponse message.

  • I have run Windows Update on both machines, there are no pending updates left.

  • I've run the SCVMM Configuration Analyzer and it only recommends applying the latest hotfixes, which I have done, and warning that the reporting server is not on HQ-VMM1.

  • One site suggested that a template created in an older version of SCVMM would fail in this manner, so I created a new template but got the same result.

I'm at a loss where to go from here. Any help is appreciated.


Over the weekend we had a power outage, and after all the servers restarted on Monday, this just worked immediately.

I know I rebooted HQ-VM2 and HQ-VMM1; I'm not sure what might have been the problem. I'll be sure to update my answer if I figure it out. Now I just feel silly that it was clearly something dumb.

  • possibly a patch that had not fully installed until after the reboot? – Kevin Colby Aug 17 '11 at 19:52

"A Hardware Management error has occurred trying to contact server HQ-VM2.domain.local."

May be a hint that this might be a name resolution situation - "HQ-VM2.domain.local." Have you tried utilizing its:

  • IP address
  • FQDN
  • The name resolves properly. "HQ-VM2.domain.local" is the FQDN. SCVMM already can contact HQ-VM2 because I can check its status and send control messages to it. – Stephen Jennings Aug 14 '11 at 14:18
  • Have you tried the IP for the remote chance that it makes a difference in this situation - if the error message is actually accurate? – user48838 Aug 14 '11 at 18:21

Have you updated your SCVMM R2 to SP1? That's probably required also.

  • Yes, SCVMM was updated to SP1. – Stephen Jennings Aug 17 '11 at 5:29
  • Are all services that are set to "Automatically" start, running on the vm hosts? – Tatas Aug 17 '11 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.