I am transferring from a server with Ubuntu on to one with CentOS and I am encountering a problem regarding cURL.

Our current site runs cURL 7.19 but Centos yum only finds 7.15. I get an error with CURLPROTO_HTTPS saying it's undefined as the version I have is too low.

I tried a manual install and it installed but when I tried to remove the yum-installed cURL it decided to remove any package that had dependencies on it, which is every package incuding PHP and mysql.

I found this tutorial on how to manually install 7.19 as there isn't (or I can't find) an RPM of cURL higher than 7.15.

Does anyone know how to get around this without re installing 20+ modules we use or to make the manual install the primary one?

If worst comes to worst the cURL code still works, I just have to comment out


I'm just not sure if that's an "ok" solution security wise, I have an SSL setup so I would hope it would be secure, but I'm not sure.


The official cURL site has pre-compiled RPMs for 7.21:


CentOS is RedHat, so find the RHEL corresponding to what you're running (I suppose you'll have either CentOS 5 or 6). Get the RPM appropriate for your architecture.

Once you have the file, you should be able to do something like "rpm -Fhv curl-7.21.7-3.0.cf.rhel6.i686.rpm" and update your default 7.15 to 7.21.

| improve this answer | |

I would probably go with one of three possibilities:

  1. Get curl 7.21 RPMs from curl.haxx.se
  2. Get curl 7.19 RPMs for CentOS 6 and recompile
  3. Get curl 7.15 RPMs for CentOS 5 and replace 7.15 source with 7.19 source

If 7.19 was absolutely required, I'd recompile the CentOS curl 7.19 RPMs (#2) otherwise I'd get RPMs directly from the original developers (#3).

Rebuilding a source RPM is quite easy; use a command like this:

rpmbuild --rebuild source.rpm

That should do it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy