I hope someone can help me with our issue we are having. We have a major issue with a process that we can not kill and the only way to get rid of the process is to reboot the machine.

I have tried killing it from the normal task manager but no joy.

I have tried killing it using the taskkill /F command from a command prompt and no joy. The command reports as sucessful but the process remains.

I have tried to start task manager with system rights by calling "psexec -s -i -d taskmgr" and attempting to kill the process but no joy

I have tried killing it from Process Explorer but again the process remains.

I have tried creating a scheduled task that runs under the SYSTEM name to kill the task but that also does not kill it :

schtasks /create /ru system /sc once /st 13:16 /tn test1 /tr "taskkill /F /PID 1576" /it

Nothing I do will kill this process. Even logging off and logging back on will not kill this process.

Using Process Explorer I notice that there is on stubborn thread that is in the Wait:Executive state. I have tried to kill this thread using Process Explorer but again no joy.

We are using Windows Server 2008 R2 64-Bit. The server is brand new and windows is freshly installed.

Now heres the thing. We have brought two identical servers from Dell with the same specs and the same OS installed and I can not replicate this issue on the other server. Only on this server, under certain circumstances does this server process hang and can not be restarted!

I have also changed the compatability mode by setting it the process to "Windows 2003" but this has not helped.

I have noticed in Process Explorer that DEP is turned on but im not sure this has got any bearing on the issue ot not.

Please, can someone help??

  • Looks like the process is hooked by the OS and is stuck in a crashing state. What is the process name? – murisonc Aug 15 '11 at 15:05
  • The Process is SchOPC.exe. It is a 3rd party OPC Server that is used to communicate to devices in the field. – adrian Aug 15 '11 at 15:21
  • In which user context is the process running? – Marcel Janus Jul 4 '13 at 11:54

This kind of issues are caused by bad drivers. Please check the drivers used by your software, the version number of .sys files etc...


See also: http://blogs.technet.com/b/markrussinovich/archive/2005/08/17/unkillable-processes.aspx

  • I have checked the drivers on both machines using the DriverView utility here: nirsoft.net/utils/driverview.html and all driver versions between the two servers are identical!!!! Where do you recommend I go from here? – adrian Aug 16 '11 at 8:38
  • How much is the CPU usage of the process with problems? – Mircea Vutcovici Aug 19 '11 at 15:08
  • The CPU usage is 0 for this process and the memory usage is 173,816K. – adrian Aug 22 '11 at 14:23

You could try Process Hacker. This open source tool has nearly the same functionality than process explorer but offers several ways to kill processes.

Right click the process and choose Miscellaneous / Terminator: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.