I have looked at this Severfault question, but my issue is slightly different.

Exchange is not delivering mail to user mailboxes or to external addresses since Saturday.

From the outside everything appears normal:

  • No NDR report is generated for email from external servers - Exchange appears to accept the message.
  • The "Messages pending submission" Queue in the Exchange System Manager has about 4700 messages in it.
  • I can telnet to the Exchange server and send a message to myself (although I don't receive it).
  • All the DNS tools I've tried report that the mail server seems OK.

If I send an email to a coworker, it doesn't appear in his mailbox, even though Outlook reports that it is connected to the server.

There are no indications in the Event logs that anything is wrong. I have run the Exchange Troubleshooting Assistant and the only warning it reports is "SMTP instance fully-qualified domain name does not match DNS resolved server name".

This is true and has been for years. The SMTP virtual server is mail.example.com, the servername is server.example.local. Our MX record is hosted on our ISP's DNS server and points to mail.example.com.

The only changed that has happened is that I raised the AD and Exchange modes from mixed-mode to native mode last week (over 7 days ago) in preparation for a migration to SBS 2011.

I've about convinced myself that this is a DNS issue, but before I go mucking about and changing the DNS as suggested in this article, I wanted to see if anyone else has seen and solved this type of problem before.

Thanks in advance for your help.

  • 1
    have you tried an iisreset and/or disabled any virus protection? – pablo Aug 15 '11 at 17:27
  • @pablo: That probably worked. Now I feel like an idiot for overlooking iisreset. Mail from this morning got delivered, but I haven't seen anything recent. But the "Messages Pending" queue is decreasing, so I'll give it a bit to work through the backlog. Thanks. – Scott McKinney Aug 15 '11 at 18:18
  • cool yeah it will probably take a while. it may be that raising the mode mucked up the smtp config and a reset put it back to the norm – pablo Aug 15 '11 at 19:10

Adding in an answer as my comment seemed to work.

Doing iisreset should reset the queues back from the AD information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.