6

I want to pass some parameters as part of my ssh connection that I can use to set custom variables for my login to do certain things or run certain scripts. How do you do this running Putty on Windows machine, connecting via SSH to a CentOS machine?

7

On the CentOS machine, create a file in your home directory named .bashrc and set your environmental variables in there. For example, the contents of the file can be:

export VARIABLE=foo

Here's some discussion of this: http://tldp.org/LDP/Bash-Beginners-Guide/html/sect_03_01.html


You can also use the SendEnv and AcceptEnv options. This will allow environmental variables on the client to be passed to the server.

You will also need to change the server's sshd_config file to specify which environmental variables are accepted by the server. I'm not sure what you'll need to do with PuTTY to issue the SendEnv option, but that should get you started.

| improve this answer | |
  • Yeah I know how to do that, but how can I pass variables over as part of my connection? – qodeninja Aug 15 '11 at 19:12
  • Edited to include the SendEnv and AcceptEnv suggestion. – cjc Aug 15 '11 at 19:32
6

You can enter environment variables in the PuTTY configuration under Connection -> Data.

enter image description here

But this works only under certain conditions. Quote from the documentation:

The Telnet protocol provides a means for the client to pass environment variables to the server. [...]

Version 2 of the SSH protocol also provides a similar mechanism, which is easier to implement without security flaws. Newer SSH-2 servers are more likely to support it than older ones.

This configuration data is not used in the SSH-1, rlogin or raw protocols.

Additionally, this has to be allowed on the server side. For the OpenSSH server the configuration directive is named AcceptEnv. On an Ubuntu server it looks like this by default:

AcceptEnv LANG LC_*

This allows you to define the variable LANG and all variables starting with LC_ in PuTTY, so you can always get the output in your preferred locale.

If you want to set additional variables you have to add them to the list on all servers you want to connect to. On older (SSH1 only) hosts it won't work at all.

| improve this answer | |
2

You could can modify PermitUserEnvironment in sshd.conf to allow processing of ~/.ssh/environment or "environment=" options on keys in ~/.ssh/authorized_keys.

The format of these two files differs. ~/.ssh/environment is lines of VARIABLBE=VALUE where in ~/.ssh/authorized_keys the environment option is environment="VARAIBLE=VALUE"

| improve this answer | |
  • 1
    Ok I found where to change PermitUserEnv but how do I pass params? – qodeninja Aug 16 '11 at 0:43
2

For those, that cannot modify sshd config for various reasons and/or have +2000 servers (and no access to mass-configuration tools or can't/don't want to change settings for other users), here's a solution I came up with:

enter image description here

In PuTTY load the desired session, go to Connection > SSH. In the "Data to send to the server" section, in "Remote command" field use:

env [OPTION]... [-] [NAME=VALUE]... [COMMAND [ARG]...] bash

Example:

env -u PS1 PS1="[\u@\h]\\$ " bash

I unset the variable first, because it didn't work otherwise.

| improve this answer | |
  • You can add variables via the Data tab as @Gerald Schneider shows in his answer. – Phill Healey Aug 18 '18 at 11:40
  • Not in my scenario. I've tried all obvious options in PuTTY first, before coming up with this hack. Please read carefully first 7 words of my answer. Gerald's answer also mentions this: this has to be allowed on the server side. – yahol Aug 18 '18 at 21:58
  • @yahol Your solution somehow deprived me from having a terminal, vim now says : Vim: Warning: Output is not to a terminal – SebMa Apr 17 '19 at 23:38
  • @SebMa what's the string you're using in "Remote command" in putty? – yahol Apr 19 '19 at 7:37
  • @yahol My command was env debug=1 bash and tty shows nothing – SebMa Apr 19 '19 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.