I have a process running queue jobs and runs other processes to complete them. Occasionally the .exe it is running fails and this causes a crash report dialog to open (WerFault.exe). This causes all the other jobs on the queue to wait until someone clicks the button on the popup.

I've messed with the settings in Control Panel > Problem Reports and Solutions, but the best I can get is a popup with no options. I've also turned off the "Windows Error Reporting" service.

How do I disable WerFault.exe?

1 Answer 1


Since you say you've already "turned off the 'Windows Error Reporting' service", I'll propose going all the way in the other direction, i.e. letting it send all data without bothering you.

Have you seen this MS Technet document mentioning the "Send all data" setting for Windows Error Reporting? From what I understand it is the only one not requiring a pop-up. However, you can't set it using the Control Panel, you have to use gpedit.msc.

  • go to Start/Run..., type gpedit.msc to open the Local Group Policy Editor
  • go to Computer Configuration\Administrative Templates\Windows Components\Windows Error Reporting\Consent
  • enable Configure Default Consent and set it to Send all data.
  • verify that Customize consent settings enabled itself at the same time; if not Enable it now.

Unfortunately I can't try this here - I currently don't have a reliable way to crash a Windows program on my current machine without dragging out a compiler ;-).

If all else fails...

Have you considered replacing WerFault.exe with an .exe that does nothing, for example true.exe from cygwin? Of course that would be a mayor step, but you could try as a last resort.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .