I'm trying to mount a remote disk using sshfs. The code is:

sshfs user@server:/ /home/user/folder

The problem could be that the remote server relogins the connecting user under a different user upon login. And therefore when i try to use this code it doesn't mount and gives me no error. How can i deal with it?

Ubuntu 11.04, server is Debian


About relogging. When i ssh into the server i see that my username is different. Our admin explained that all users are logged into the server under one user. He tried creating an sshfs under a user that does not get relogged and it worked. But as my user is switched to a common user sshfs doesn't work for me.

I tried sshfs with -o debug and it showed nothing - it just freezes after i enter the correct password on the server.


loglevel=debug3 after entering password

 debug3: packet_send2: adding 48 (len 61 padlen 19 extra_pad 64)
 debug2: we sent a password packet, wait for reply
 debug1: Authentication succeeded (password).
 debug2: fd 4 setting O_NONBLOCK
 debug3: fd 5 is O_NONBLOCK
 debug1: channel 0: new [client-session]
 debug3: ssh_session2_open: channel_new: 0
 debug2: channel 0: send open
 debug1: Requesting no-more-sessions@openssh.com
 debug1: Entering interactive session.
 debug2: callback start
 debug2: client_session2_setup: id 0
 debug1: Sending environment.
 debug3: Ignored env ORBIT_SOCKETDIR
 debug3: Ignored env SSH_AGENT_PID
 debug3: Ignored env TERM
 debug3: Ignored env SHELL
 debug3: Ignored env XDG_SESSION_COOKIE
 debug3: Ignored env WINDOWID
 debug3: Ignored env GNOME_KEYRING_CONTROL
 debug3: Ignored env GTK_MODULES
 debug3: Ignored env USER
 debug3: Ignored env LS_COLORS
 debug3: Ignored env SSH_AUTH_SOCK
 debug3: Ignored env DEFAULTS_PATH
 debug3: Ignored env SESSION_MANAGER
 debug3: Ignored env USERNAME
 debug3: Ignored env XDG_CONFIG_DIRS
 debug3: Ignored env DESKTOP_SESSION
 debug3: Ignored env PATH
 debug3: Ignored env PWD
 debug3: Ignored env GDM_KEYBOARD_LAYOUT
 debug1: Sending env LANG = en_US.UTF-8
 debug2: channel 0: request env confirm 0
 debug3: Ignored env MANDATORY_PATH
 debug3: Ignored env GDM_LANG
 debug3: Ignored env GDMSESSION
 debug3: Ignored env SHLVL
 debug3: Ignored env HOME
 debug3: Ignored env GNOME_DESKTOP_SESSION_ID
 debug3: Ignored env LOGNAME
 debug3: Ignored env XDG_DATA_DIRS
 debug3: Ignored env DBUS_SESSION_BUS_ADDRESS
 debug3: Ignored env LESSOPEN
 debug3: Ignored env WINDOWPATH
 debug3: Ignored env DISPLAY
 debug3: Ignored env LESSCLOSE
 debug3: Ignored env XAUTHORITY
 debug3: Ignored env COLORTERM
 debug3: Ignored env _
 debug1: Sending subsystem: sftp
 debug2: channel 0: request subsystem confirm 1
 debug2: fd 3 setting TCP_NODELAY
 debug2: callback done
 debug2: channel 0: open confirm rwindow 0 rmax 32768
 debug2: channel 0: rcvd adjust 2097152
 debug2: channel_input_status_confirm: type 99 id 0
 debug2: subsystem request accepted on channel 0
  • 1
    "The problem could be that the remote server relogins the connecting user under a different user upon login" --> could you explain more details? Also try with sshfs -d -o debug ... to see what does it say?
    – quanta
    Aug 19, 2011 at 14:38
  • Re: your edit, It's best if you don't do anything funky when using sshfs. Your configuration ("all users are logged into the server under one user") is the poster child for "funky" :-)
    – voretaq7
    Aug 19, 2011 at 16:18
  • voretaq7: Is it dangerous?
    – barin
    Aug 19, 2011 at 16:40

1 Answer 1


Your administrator seems to have done something usual. We don't have enough information to know what "relogging" means. It could be the sshd config, it could be some shell script, we just don't have enough information.

The real answer here is, ask your IT folks to solve this problem for you. They've already given you a fluffy explanation of what's going on, possibly because they don't think you'll understand the setup, and you just don't have the information you need to help yourself. Speaking as a professional Sysadmin, sometimes it's absolutely astounding how much effort people will put into solving an issue for themselves before asking for help.

  • yeah, i just had to ask the admin... ;) he fixed it.
    – barin
    Aug 23, 2011 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.