I've been trying to mount an ISO file on Windows Server 2008 without success. I've tried MagicISO, Daemon Tools, and Pismo Disk Mounter, but all of them give me some error or another. I'm guessing this is some security issue, but I'm not sure how to get around it. Has anyone had luck with this?


4 Answers 4


Why do you need to actually mount the ISO? Instead of installing unnecesasry 3rd party apps on your server, why not just use something like 7-zip to extract the contents of the ISO?

  • 1
    Great idea, I didn't know 7z could do that. Aug 19, 2011 at 20:34
  • 2
    Unzipping ISOs to disk in order to do software installs doesn't seem like a great approach. Especially taking into account how long it takes to unpack, and how much disk space it takes, relatively speaking ... that's WHY mounting ISOs is built in on later OSes, and why there are so many utilities (including one from Microsoft) for mounting them.
    – Jaykul
    Sep 23, 2014 at 18:48
  • @Jaykul What's worse? Temporarily eating up a few GB of disk space that you can immediately free up after, or installing unnecessary software on your servers? For me, I'll unzip on my workstation and copy the installation files 10 out of 10 times if I'm working with a legacy Windows OS.
    – MDMarra
    Sep 23, 2014 at 20:16

Have you tried Virtual CloneDrive?

Alternately, 7-Zip can open ISOs and extract their contents.

Both freeware, I use them often, VCD works on 2008 R2 SP1 for me.

(Still, three programs not doing it ... are you sure it's not a corrupt ISO?)

  • +1 for the tip on VCD in case CD won't install from HDD
    – Praesagus
    Dec 22, 2012 at 0:25

Why not use Microsoft's tool... http://www.microsoft.com/en-us/download/details.aspx?id=38780

  • 2
    Notes: This tool is not supported by Microsoft; use at your own risk. - Not what I'd like to install on a production server.
    – MDMarra
    Sep 23, 2014 at 20:17
  • Honestly, I tried it yesterday, and ended up using Virtual CloneDrive anyway after this thing failed to work right. I'll probably just delete this suggestion.
    – Jaykul
    Sep 24, 2014 at 16:55

Assuming you're not running VMWare (where you could mount it in vSphere) you could try PowerISO. That's what I use and it works well.

Not the answer you're looking for? Browse other questions tagged .