I am using Putty 0.61 to ssh into an Ubuntu server (10.04.3) from Windows 7. Whenever I try to view a man page, inevitably there are many characters that are missing from the man page.

The TERM environment variable is set to xterm. The locale command says that LANG=en_US.UTF-8. Putty is set to use UTF-8 under the Translation menu. Here is the output of stty -a:

speed 38400 baud; rows 33; columns 114; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q;
stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke

The font I am using in Putty is Courier New.

Another strange terminal issue is that when using Emacs and doing auto-complete for files, the first letter of the file is missing.

UPDATE (2011-08-21): If I use my mouse to select a region of the displayed man page, then the screen colors invert: my normal background of white turns black and the text itself turns from back to white. This is to be expected, but the strange thing is that when this happens I can also see the missing text! The missing text that shows up when highlighted seems to be a shade of grey. So, it has something to do with how colors are displayed.

If I check the box "Use system colours" under "Windows|Colours" in Putty, I can now see the missing/invisible text.

4 Answers 4


This is usually a font issue. Fonts often lack glyphs for many characters, so try some different ones. DejaVu Sans Mono is free and fairly comprehensive.

  • I tried changing to DejaVu Sans Mono but still the same issue: missing characters.
    – user35042
    Aug 22, 2011 at 4:46

PuTTY's default translation is ISO-Latin-1. Ubuntu's default console locale is based on UTF-8. You have to change one of them to match the other. In PuTTY, change the translation to UTF-8, or from terminal set the locale with LC_ALL to ISO-Latin-1.

  • As my post states, the locale on the Ubuntu side is en_US.UTF-8 while Putty is set to use UTF-8. That does not seem to be enough to solve the problem.
    – user35042
    Aug 22, 2011 at 4:49
  • If you use screen do you hit the same problems? Aug 22, 2011 at 4:59
  • I typed screen and then man dpkg and I still see (or, rather, don't see) many of the characters.
    – user35042
    Aug 22, 2011 at 5:04
  • See also the update.
    – user35042
    Aug 22, 2011 at 5:10

I ran into this issue as well, and your comment about colors might be the cause.

I like to switch the colors, so that the background is white, and the text is black. I also had disappearing characters in manpage output, as you describe. In the Putty configuration panel, note that there are color settings for "Default Background" as well as "Default Bold Background", and the same for foreground. This issue went away for me when I set the "Bold" versions to the same colors as the normal ones. It turned out that the missing characters were all being displayed in bold.


export LANG=C

I bet your man pages will work fine =)

If you don't have a reason to be using unicode manpages this will turn it off and set programs to use their 'default'.

  • I tried this but it did not affect the appearance of the man pages.
    – user35042
    Aug 22, 2011 at 4:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.