I have purchased one SSL certificate which should run on domain and subdomain. E.g. *.example.com.

I want this SSL certificate to run in domain website and subdomain website. I have two different Website in IIS 7.0

  1. example.com
  2. xyz.example.com

Currently the SSL certificate is assigned to xyz.example.com and it is working very well.

Now I want this certificate to work in example.com website as well. I have added the certificate and it has taken default port for https i.g. 443. Now when I have start the website, it gives me below message:

This Web site cannot be started. Another Web site may be using the same port.

Now, I have changed the default port of https i.g. 443 of example.com to 445. and tried to start the website and it gives me below message:

The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

Can you please help me in this.

Thanks in advanced


  • Can you please provide your configuration information for the two vhosts.
    – womble
    Aug 25 '11 at 7:19

IIS does not support Name based virtual hosts with SSL. Basically you need a separate socket (IP+PORT) for each site.

Port 445 is almost certainly in use for by the Windows File and Print Sharing Services (SMB).

In the future please consider using a command like netstat -a -n and verify that nothing is listening on a port before you try to assign it to something else.


According to recent announcements, IIS8 will support what you are looking to do.


IIS 8.0 support Server Name Indication (SNI), which has extended TLS to include the virtual domain name to be passed from the client at the time of "SSL Hello". This effectively allows IIS 8.0 to enable "hostname binding" for SSL sites, which eliminates the need for having a dedicated IPv4 address per SSL site.

  • One of the quickest ways of drawing attention to yourself and look like a spammer is to post identical answers to old questions.
    – user9517
    Mar 15 '12 at 14:28
  • lol, right? I was wondering why this was popping up...
    – JohnThePro
    Mar 15 '12 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.