I have the lastest stable Wamp Server running on a Windows Server 2008 R2 (x64) box. I'm trying to run PHP 5.2.11 for an old site. 5.2.11 works just fine in WAMP Server until I enable the PHP_MSSQL extension, apache no longer starts. Disabling php_mssql in php.ini fixes it. Apache DOES however start if I run an older version of PHP with php_mssql on; however the old version has unacceptable query times, 20x longer for some queries.

Is there any reason this might not work? It's only the php_mssql plugin. I tried to find the latest but was unsuccessful; I know the php_sqlsrv.dll extension is superior, however I'm using an old version of cake and I need php_mssql to use their drivers.


Simple answer, the php_mssql version was broken. Used an older version that shipped with php 5.2.9 and it did work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.