I'm trying to configure the ARR, but can't seem to find it anywhere in the IIS management tool.

I've checked for permission issues (both during the install and when starting the IIS Manager). ARR shows up as an installed program, and I've tried install/uninstalling it.

What could be the problem?


Server Farms should be the UI branch from which it's configured. The top level of a given farm shows its ARR properties.

If you haven't closed/reopened the Inetmgr GUI since installing it, you need to do that too.

  • Do I need to turn on some windows' feature before I can see the server farms section of the UI? – blueberryfields Aug 28 '11 at 23:15
  • Actually, I think I've just worked out what the problem is: You haven't installed ARR yet? If not, go to iis.net and use the Web Platform Installer to install ARR, which installs Web Farm Framework, which adds the UI I'm talking about. ARR is not a built-in feature of IIS, it's a downloadable add-on. – TristanK Aug 29 '11 at 5:25
  • I've installed ARR - I've said that in the question. I've also checked whether this is an issue with permissions when installing or when starting the manager – blueberryfields Aug 29 '11 at 14:10
  • Are you certain it's the Server Farms UI branch? I don't see anything in that branch for my machine (and it doesn't seem to me that ARR is specific to Server Farms, though I might be wrong on that) – blueberryfields Aug 29 '11 at 23:07
  • Yes, ARR works with the Web Farm Framework. You need a server farm defined before the ARR extras show up. – TristanK Aug 30 '11 at 5:29

I also could not find the ARR icon when using the server manager. But when I went to control panel, admin tools, iis manager, the ARR icon was there.

  • 1
    Solved the issue for me. Not sure why the answer above was chosen. – Yaroslav Yakovlev Dec 4 '13 at 12:48

I got this problem on Server 2012 R2, I usually start IIS Manager form the command line

It turned out when using:


the ARR icons are missing, but when using


they show up just fine.

On Server 2012 R2, both Administrative tools and Server Manager use InetMgr.exe, so both should work, on older OSes, there may be links using iis.msc

  • %windir%\system32\inetsrv\InetMgr.exe did the trick, finally the icons show up! Thanks for the hint! – user208549 Feb 7 '14 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.