I have purchased a dedicated server some days ago and I think I don't have enough knowledge to configure its DNS etc. Well, I'll describe my situation.

I have a dedicated server for virtualization, it is a SolusVM Xen Slave. My SolusVM Master is a simple VPS in another provider. Inside this dedicated server I have some VPS: 1 - A personal VPS, doesn't matter. 2 - A VPS with Plesk 10 installed. 3 - A VPS with cPanel installed. 4 and 5 - Small VPSs that are SolusVM DNS Servers, they are used to manage rDNS to other VPS inside the dedicated.

I also have the domain rafaa.me. This domain is registered with Dynadot and I have a Google Apps account for it. My personal email is x@rafaa.me and I have an email z@rafaa.me which is used for some of my websites. For example, I have a small website that sends some info to registered users every morning. This website used to use Google mail servers to send the emails, but due to the Google policies they suspended z@rafaa.me in my Google Apps account.

According to this I concluded that I would need my own mail server in order to send the emails normally without getting suspended. That is because I installed the Plesk and the cPanel VPSs (among other reasons).

Well, I described my situation. Now I will ask for help and below I will describe what solution I tried, which didn't work.

My question is: how do I proceed in order to send emails correctly FROM z@rafaa.me (which is in Google Apps) THROUGH my Plesk mail server?

Let me describe the solution I tried, which didn't work.

I created the domain rafaa.me in Plesk. Created an email called z@rafaa.me inside this domain in the panel. So far, so good. I ran a test script using SMTP authentication to send emails in another VPS. The script works successfully, I could send emails successfully FROM z@rafaa.me THROUGH the Plesk mail server.

Now the problem.

The problem is: it didn't work when I try to send an email (using the PHP script, of course) FROM z@rafaa.me THROUGH Plesk mail server TO some @rafaa.me email. It gives me:

Failed to add recipient: x@rafaa.me [SMTP: Invalid response code received from server (code: 550, response: 5.1.1 : Recipient address rejected: User unknown in virtual mailbox table)]

What I think the problem is.

Well, the mail server is not dumb. I think he's assuming rafaa.me is in the local server so it doesn't need to look for another server trying to find x@rafaa.me. And I thought that it was happening because Plesk has its own nameserver, and the MX records in this nameserver was pointing to itself.

Trying to solve I disabled the Plesk nameservers and told Plesk to search in Dynadot nameservers. It didn't work too.

I really do not know how to proceed. Would someone explain me how to proceed with this issue?

Any help would be appreciated.

Thank you, Rafael Andreatta

  • Plesk is not a mail server, or a dns server. It is simply a control panel. At the moment, I have no idea what mail server you are running, or how it is configured.
    – Zoredache
    Aug 27, 2011 at 4:19

2 Answers 2


"Created an email called z@rafaa.me inside this domain in the panel."

"Failed to add recipient: x@rafaa.me [SMTP: Invalid response code received from server (code: 550, response: 5.1.1 : Recipient address rejected: User unknown in virtual mailbox table)]"

Was an account/email created for x@rafaa.me via the process as z@rafaa.me?

  • No. I just created z@rafaa.me in Plesk, because I only want to send outgoing emails from z@rafaa.me not from x@rafaa.me. So there is no need, in my point of view, to create x@rafaa.me in Plesk. Am I doing it wrong?
    – rafaame
    Aug 27, 2011 at 16:29
  • According to the error message, in order to receive email (or have it be a target address on/for your system in this case) it needs an account established for the identified recipient.
    – user48838
    Aug 27, 2011 at 17:18

In plesk, you will need to completely disable mail service for the domain rafaa.me to make this working. Otherwise, plesk will check the @rafaa.me email accounts always locally and won't see the actual MX for google.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.