I am able to set both APM and spindown times using the command:

hdparm -S 246 -B 128 /dev/sda

Unfortunately I can only find the APM value in the information output:

hdparm -I /dev/sda | grep Advanced

How can I see the spindown time value? I suspect my disc it is ignoring my value. I would like to see it. Tried smartctl but with no luck, help.

Update: It turned out tuned is very aggressive. When I turned it down, my discs does not spin down. It was setting something there.


There does not seem to be a way to query that value with hdparm, however you can see if the drive is in a standby or active state...

> sudo hdparm -C /dev/sdb

 drive state is:  standby

> sudo hdparm -C /dev/sda

 drive state is:  active/idle
| improve this answer | |

The option -B 128 inhibits spindown, so your -S option is useless. Have a look at man hdparm. Spindown is only possible with -B parameters of 127 and less.

| improve this answer | |
  • 1
    Yes. But additionally on my Samsung drive "-B 127" did a spin down before the with -S configured time of 15 minutes. This means you might want to set it even higher to allow the spin down time setting to work. I also found this information here askubuntu.com/a/733242/397064 which suggest a setting of "-B 150" which works for me too. The disc will then spin down after the specified time. – Benjamin Peter Apr 15 '16 at 19:16

The output from man hdparm includes the following:

-S: Put the drive into idle (low-power) mode, and also set the standby (spindown) timeout for the drive. This timeout value is used by the drive to determine how long to wait (with no disk activity) before turning off the spindle motor to save power. Under such circumstances, the drive may take as long as 30 seconds to respond to a subsequent disk access, though most drives are much quicker. The encoding of the timeout value is somewhat peculiar. A value of zero means "timeouts are disabled": the device will not automatically enter standby mode. Values from 1 to 240 specify multiples of 5 seconds, yielding timeouts from 5 seconds to 20 minutes. Values from 241 to 251 specify from 1 to 11 units of 30 minutes, yielding timeouts from 30 minutes to 5.5 hours. A value of 252 signifies a timeout of 21 minutes. A value of 253 sets a vendor-defined timeout period between 8 and 12 hours, and the value 254 is reserved. 255 is interpreted as 21 minutes plus 15 seconds. Note that some older drives may have very different interpretations of these values.

Your setting of 246 would therefore mean 6 units of 30 minutes (3 hours), although I don't know how the value for -B is interpreted when -S is also specified.

| improve this answer | |

If you have a Seagate disk which support Extended Power Controls (EPC), I assume mostly enterprise class, you can use the tool SeaChest
First get the Seagate disk handle:

 SeaChest_PowerControl -v 0 --scan --scanFlags sgtosd


 Vendor   Handle       Model Number            Serial      Number          FwRev
 ATA      sg0<->sda    ST1000LM049-2GH172      WN90H8BT               SDM1
 ATA      sg1<->sdb    ST1000LM049-2GH172      WN90HACK               SDM1
 ATA      sg2<->sdc    ST1000LM049-2GH172      WGS3M35X               SDM1
 ATA      sg3<->sdd    ST1000LM049-2GH172      WGS65M4X               SDM1
 ATA      sg4<->sde    ST1000NX0303            S470WNPT               NN02
 NVMe     /dev/nvme0n1 Force MP510             184282050001276960F1   ECFM11.0

Then get the standby time:

 SeaChest_PowerControl -v 0 -d /dev/sg4 --showEPCSettings


 ===EPC Settings===
    * = timer is enabled
    C column = Changeable
    S column = Saveable
    All times are in 100 milliseconds

 Name       Current Timer Default Timer Saved Timer   Recovery Time C S
 Idle A     *200          *10           *200          150           Y Y
 Idle B      1200         *2400          1200         650           Y Y
 Idle C      1300          6000          1300         4000          Y Y
 Standby Z  *1200          36000        *1200         15000         Y Y

(Don't mind my experimental Idle_C and Standby_Z values which is very low)

You can get the tool from Seagate

The above example is from a Seagate Enterprise Capacity 2.5" 1TB SATA (ST1000NX0343). Tried the same on a Seagate BarraCuda Pro 2.5" 1TB SATA (ST1000LM049) and it didn't work, as it apparently doesn't support EPC.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.