1

If I turn off the firewall on Windows SBS 2011, I can connect to my SQL Server 2008 non-default instance by name (which I presume means it's using named pipes) without incident. After I turn it back on, I can't. I have unblocked incoming TCP and UDP ports 135, 139 and 445.

What am I missing?

2

Here is a link that explains what you could do to resolve this issue

http://msdn.microsoft.com/en-us/library/ms175043.aspx

| improve this answer | |
  • 1
    Odd. The article says I should open UDP 1434. When I do that, nothing happens, but opening TCP 1434 works. – Marcelo Cantos Aug 29 '11 at 6:10
  • 1
    Scratch that. It looks like I'm seeing some kind of lag or caching. It stopped working a couple of minutes after I opened TCP 1434, and didn't work again until I opened UDP 1434 (and disabled TCP 1434). – Marcelo Cantos Aug 29 '11 at 6:16
  • It does say to open a TCP port, its on line 4 of the "To open a port in the Windows firewall for TCP access" part under the "Windows Vista and Windows Server 2008 and later" Heading – enterzero Aug 29 '11 at 6:18
  • Ok, well I am happy it is working for you now. – enterzero Aug 29 '11 at 6:21
  • That's TCP 1433 for the default instance, and isn't relevant to named pipes, afaik. – Marcelo Cantos Aug 29 '11 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.