In my OCZ 240GB PCI-Express SSD, I create huge files and after write about two files 45GB and 45GB the software throw exception "The requested operation could not be completed due to a file system limitation" While there are a lot of space out there.

I tried to investigate the problem, and some people said it maybe fragmentation problem. I tried to solve it by remove all the files from this partition so append in the huge files will not make fragmentation but the problem still there.

In this partition I have 40 files, two big (The files I try to creates) and the other files small (meta data) and the there are 6 fragmented files, and total file fragments is 3768243 - This information from defrag /v

I have Windows Server 2008 R2 - is there is any advice?


I think this is probably relevant:


The actual limit isn't on the # of fragment, but on the number of records of the data segment that stores the pointers to the fragment.

It's very possible that with that many fragments, the filesystem itself is unable to add more fragements. An easy way to test is by using the Contig utility that the other article locked to defragment the files, and try again. If you cannot defragment the file, or if you can subsequently write to the file correct after defragmenting it, you will have your answer.

Another approach you should consider is rolling over your files at . The larger your files (especially ones you are appending incrementally) the more likely you will get fragmentation as NTFS struggles to find contiguous space for your file. (though this is the first I've heard of that happening on an empty disk, perhaps befcause you have multiple large files). Rolling at ~2G will probably improve this dramatically.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.