We have a number of HP DL385 G2s which kernel panic after installing RHEL 5.3. All are up-to-date with firmware CD 8.50. The initial RHEL 5.3 installation always works and in most cases the first boot is fine (kernel 2.6.18-128.el5); so far 1 in 4 has paniced here. Most of the rest of the machines I've tried fail to boot when "yum update"d to kernel 2.6.18-128.1.10.el5. One or two have been fine.

The panic is always at the same point. The last lines logged on the console are:

device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.11.5-ioctl (2007-12-12) initialised: dm-devel@redhat.com
usb 4-2: new full speed USB device using uhci_hcd and address 3
device-mapper: dm-raid45: initialized v0.2429
usb 4-2: configuration #1 chosen from 1 choice
hub 4-2:1.0: USB hub found
hub 4-2:1.0: 7 ports detected

then a pause, then:

kernel panic - not syncing - attempted to kill init

Beyond this point no kernel will boot (including the Anaconda-installed 2.6.18-128.el5) and a reinstall is the only option. It seems very similar to this problem reported on the HP forums.

So, any ideas? We have DL385 G2s on RHEL 5.2 so something in 5.3 isn't playing well with the same hardware. We've tried factory resetting the BIOS, etc. How do I work out what the kernel's up to? (I've already removed "rhgb quiet" from the append line.) Luckily we don't have too many of these boxes and I have a little time to investigate.


Have you tried updating the BIOS and all other firmware?

  • Yep, as mentioned above :~) – markdrayton Jun 24 '09 at 9:00
  • You say 'resetting' - it wasn't clear what you meant. – Chopper3 Jun 24 '09 at 9:28
  • Fair point -- sorry for my snarky reply. It looks a bit like resetting to factory defaults after updating the firmware might help.. – markdrayton Jun 24 '09 at 15:59

A good practice for any server is to disable any onboard stuff you don't need (this is usual practice with vmware servers). Since your last lines are about USB, how about turning the USB controller off?

Edit: removed talk about firmware, didnt see first that you already had it patched


Are you using HP provided drivers for any hardware? If so, try using vanilla kernel drivers only. Also try disabling usb by adding "nousb" and the end of the kernel line in grub.


A colleague has seen a similar issue on a g5 moving to 5u3.

It looks like the PSP version we were using on 5u2 (8.15) doesn't play nice with 5u3. We didn't end up with it being unbootable though. We were able to boot an old kernel, upgrade the PSP to 8.20 and then go back to the new kernel.

Then of course we found this.


  • Thanks for this. It's not relevant in our case because we don't use the PSP but it's good to be aware of the issues around it. It seems that a BIOS reset has done the trick for us... – markdrayton Jul 17 '09 at 4:26

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.