I'm trying to install nginx apt-get install nginx on my Debian Lenny, but I can't cause of this:

The following information may help to resolve the situation: The following packages have unmet dependencies: nginx: Depends: nginx-full but it is not going to be installed or nginx-light but it is not going to be installed E: Broken packages

Any idea what could be wrong?

Edit: apt-get install nginx-light

The following packages have unmet dependencies: nginx-light: Depends: libc6 (>= 2.10) but 2.7-18lenny7 is to be installed Depends: libpcre3 (>= 7.7) but 7.6-2.1 is to be installed Depends: libssl0.9.8 (>= 0.9.8m-1) but 0.9.8g-15+lenny11 is to be installed E: Broken packages

  • nginx-light has other dependencies out of which at least one has issues. Try apt-get nginx-light and post here the new set of complains from apt-get (eventually for all the unmet deps try an apt-get install and see which doesn't want to install).
    – O G
    Sep 5 '11 at 13:31
  • Added the output from apt-get install nginx-light. I tried upgrading or installing again those libraries but I think I can't install newer version than that.
    – Rihards
    Sep 5 '11 at 13:38
  • Problem is with libpcre3 and libssl0.9.8, for which lenny does not have recent updates. You could try to install them from the squeeze repository (change repo to squeeze and try installing only those), but be careful on what else it will try to upgrade.
    – O G
    Sep 5 '11 at 14:04
  • I managed to install them from lenny-backports! Yay!
    – Rihards
    Sep 5 '11 at 14:08
  • Long since I needed that :) Well, you're all set then.
    – O G
    Sep 5 '11 at 14:11

It actually appears other developer had installed PHP 5.3 himself and so the whole thing was somehow failing. Once i uninstalled it and installed PHP from Debian packages it all went smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.