I, stupidly, uninstalled Python (I was having trouble with it for something else I needed) and didn't realise Yum needed it. So when I tried installing Python with a Yum command of course it didn't work.

I've managed to reinstall Python, and am now trying to get Yum working again but to install the Yum RPM I need some other dependencies installed, however one RPM needed is elfutils-libelf

I'm trying to install elfutils-libelf using the following command:

rpm -Uvh http://mirror.centos.org/centos/4/os/i386/CentOS/RPMS/elfutils-libelf-0.97.1-5.i386.rpm

When I run that command I get the following output:

error: Failed dependencies: elfutils-libelf = 0.97-5 is needed by (installed) elfutils-0.97-5.i386

Seeing as that's the RPM I'm trying to install, it doesn't make an awful lot of sense, to me.

I ran the following command and got the following output:

rpm -qa | grep elfutils-libelf


So it looks installed.... I've tried uninstalling it to reinstall it but there's other dependencies preventing me from doing that.

My knowledge on Linux is very limited, so forgive me.


I ran the following command:

wget http://mirror.centos.org/centos/4/os/i386/CentOS/RPMS/elfutils-libelf-0.97.1-5.i386.rpm rpm -i elfutils-libelf-0.97.1-5.i386.rpm

And got the following output:

file /usr/lib/libelf.so.1 from install of elfutils-libelf-0.97.1-5 conflicts with file from package elfutils-libelf-0.97-5

2 Answers 2


Sure it seems weird...

Can you boot in rescue mode from the installtion CD ?

If yes, you could use the yum command from the rescue system to reinstall yum on the system...

Yum should have the "installroot" option available so...

Should I try to remember how to do it ?

  • I'm not sure where my disc is at the moment, so I'll go digging for it. I'll see what I can do when I put the disc in, I'll see what options come up :) Thanks Sep 7, 2011 at 13:24
  • Turns out the installation CD was a Mistero - Web Server disc. It has things like BlueQuartz and Webmin on it. I can't boot with this to boot into a rescue mode. Sep 7, 2011 at 14:11
  • I copied the rpm's from the disc to my computer, then FTP'd them onto the server, and reinstalled ... Turns out it was still a Python problem. I think I had the wrong version or something. Just some minor yum issues to fix now. Thanks! :D Sep 7, 2011 at 14:26

You should upgrade elfutils instead:

rpm -Uvh http://mirror.centos.org/centos/4/os/i386/CentOS/RPMS/elfutils-0.97.1-5.i386.rpm
  • When I run that command I get the same error as before: Sep 6, 2011 at 14:06
  • error: Failed dependencies: elfutils-libelf = 0.97.1-5 is needed by elfutils-0.97.1-5.i386 Sep 6, 2011 at 14:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .