I have a leased line which is capped @ 10mbit/sec up & down. Border device is a Draytek Vigor 3300V+. I have a couple of Dell servers running Windows 2003 behind the Draytek. My issue is that the upstream speed from the servers maxes out at about 7-8mbps when accessing them from another location. As a test, I installed Ubuntu on a laptop & stuck it along side the two servers. I ran the same tests from that machine, and the upstream was a steady 10mbps as you'd expect. I've run both iperf and http tests, with the same results. If I access the machines locally, it's nice and fast as you'd expect on a LAN. They just seem to be unable to effectively make use of the 10mbps bandwidth available to them on the leased line. I've tried all sorts of things in an attempt to diagnose what could be the issue affecting the Windows machines, but without any luck. Here's some of the things I've tried...

  • Updating network drivers
  • Disabling/enabling various advanced settings on the NICs
  • Running Wireshark traces and seeing if I can spot any obvious problems
  • Latest firmware on the Draytek
  • Ruling out any other network equipment (switches, cables)

A few more details that might be relevant:

  • Both servers are Dell PowerEdge 2800 machines
  • Both run Windows 2003 Server (SBS Edition & Standard Edition) R1
  • Both machines have Intel Pro 1000 MT Dual Port adapters

My networking knowledge really isn't up to scratch to diagnose this problem easily. I'm busy brushing up on my low level network in the hope of being able to draw more from the Wireshark traces that I have. Any thoughts of anything else I could try would be very much appreciated.

  • 1
    what protocol are you using to test, cifs per chance? – tony roth Sep 6 '11 at 22:09
  • The usual test I run is HTTP, which is obviously TCP at the transport layer. I've also run iperf, which uses it's own protocol in both UDP and TCP mode. I wouldn't use SMB/CIFS as a test since I know how badly it can perform over WAN links – dbr Sep 6 '11 at 22:53
  • so visiting the same http site on each platform gives different results. Or is there a windows verison of iperf that you did a apples to apples comparison with. If not then the tests are not accurate. – tony roth Sep 9 '11 at 4:26
  • Hi Tony - Yes, I used a Windows version of iperf on the Windows machines. The HTTP tests were done using the same 512mb test zip file, served from either Apache or IIS. Average throughput was roughly the same on both iperf and HTTP tests, suggesting it wasn't anything like an Apache vs IIS performance issue and more likely something OS/network/hardware related. – dbr Sep 9 '11 at 8:44
  • Just to be clear, both iperf & http tests were run on both platforms. – dbr Sep 9 '11 at 9:12

Did you try disabling the QOS scheduler on the network adapters? 7-8 is right around 20% of the maximum speed, which according to http://support.microsoft.com/kb/316666 is the limit as to what programs can reserve through the QOS scheduler.

Also, check that the MTU of the adapters is set correctly for whatever your internet connection can handle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.