Issue: I'm having issues getting WebDav to work in the command line on Windows XP, both Service Pack 2 and Service Pack 3.

C:\>net use z: https://mywebsite.com/software/
System error 67 has occurred.

The network name cannot be found.

I have tested this with two webdav server. Both Ubuntu Apache and I Windows Server 2003 IIS. Both get the same result.

Things That Haven't Worked:

  1. I've installed the following Microsoft KB on my XP machines with no avail.
  2. I've also found the following reg key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters UseBasicAuth REG_DWORD 1

  3. I try the following when trying to use a few work around I've dug up on the web, all producing the same result.

    net use z: https://mywebsite.com/software
    net use z: https://mywebsite.com/software#
    net use z: https://mywebsite.com/software/
    net use z: https://mywebsite.com/software/#
  4. I've also tried all the above combinations adding a user into it /user:user and /user:user@domain.

  5. I've also tried using http:// rather than https://.

  6. I've tried "\\server.com@ssl:443\folder"

  7. I've gone over networking related issues as @WesleyDavid had pointed out.

Things that do work:

  • I can connect to the webdav folder via the URL and with mapping in Network Place, with XP. But the command line doesn't work (I need a drive letter).
  • Windows 7 works perfectly with the same command.

My Delemma:

I need this to work with a drive letter. What else can I try to get this working?

  • Please try the steps listed here: smallvoid.com/article/winnt-webdav-network-drive.html ... ensure you enquote the URL string.
    – iivel
    Sep 7, 2011 at 0:46
  • @iivel I've tried that. Updated my question with it.
    – Nixphoe
    Sep 7, 2011 at 1:11
  • You did try net use z: "https: slash slash mywebsite.com/software/" correct? (sorry but I don't know how to put a link in a comment without a link.
    – iivel
    Sep 7, 2011 at 2:49
  • @iivel I've tried that, it's in my question.
    – Nixphoe
    Sep 7, 2011 at 13:55
  • What type of OS/Web Server is hosting the site at mywebsite.com ?
    – pk.
    Sep 7, 2011 at 14:05

8 Answers 8


Using WedDAV enabled on OS X Lion Server, the syntax in XP is:

NET USE * http://server url/webdav/username password /user:username

This works, but can not figure out how to choose from multiple shares for the same user (it always defaults to the user account directory)...


I had the same problems for a HTTP WebDav connection (did not try with HTTPS yet but it should work too). Please try the following, it worked for me:

To enable Basic authentication on the client computer, follow these steps:

  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type UseBasicAuth, and then press Enter.
  6. On the Edit menu, click Modify.
  7. In the Value data box, type 1, and then click OK. Note Basic authentication is enabled if the UseBasicAuth registry entry is set to a non-zero value. Basic authentication is disabled if the UseBasicAuth registry entry is not present or if the UseBasicAuth registry entry is set to 0 (zero).
  8. Exit Registry Editor, and then restart the computer.

Note that the key is called BasicAuthLevel in Vista and newer

Then connect

net use X: "http://mywebsite.com/software" /User:username password

Source http://support.microsoft.com/kb/841215/en-us

  • That was on step 2 of things that didn't work, for me anyway. Wonder what else could be different.
    – Nixphoe
    Oct 22, 2012 at 15:14
  • @Nixphoe did you try the quotes and providing password directly ... for me having a different syntax than the one described also did not work
    – dwn
    Oct 30, 2012 at 9:55
  • Didn't work for me. Had the same system error 67.
    – Nixphoe
    Nov 1, 2012 at 19:05

Zero Guess: I just edited this in here. Get rid of the trailing slash in net use z: https://mywebsite.com/software/ so that it reads net use z: https://mywebsite.com/software

First guess:

I don't like the look of /user:user@domain. I've seen sketchy things happen with that in some Windows CLI tools (even though, yes, it should work fine). Did you try the format /u:domain\user?

Second Guess:

  1. Go into hardware management and select to View >> "Show Hidden Devices"
  2. Open the "Non Plug and Play Drivers" Node
  3. Disable IP Network Address Translator

That has been known to cause error 67, which is the heart of the problem. A communications error.

Third Guess

Winsock corruption! It happens. Look into netsh winsock reset and netsh winsock reset catalog

You can read more at this KB article.

Fourth Guess:

Sometimes error 67 can be caused by a hardware level issue on both the client and server side, usually involving the drivers. Two possibilities:

  1. Reset the TCP/IP stack on the client using netsh int ip reset. I know, I know - it's cargo cult administration. Just try it. =)
  2. Update to the latest network drivers for the exact card model number on all machines involved. Even the servers. In my mind somewhere, I seem to recall error 67 being thrown on clients and the server network card being updated to solve the issue.

Fifth guess

We're getting down to thin pickins down here. Try this in Safe Mode with Networking. WebDAV connections should be able to be made. I'm wondering if some interfering extraneous network driver is interfering, although that should have been taken care of my updating the drivers in Guess #1.

  • I really wish I could have something more for you with that most thorough answer. But none of that worked. <sad face>
    – Nixphoe
    Sep 8, 2011 at 15:21
  • @Nixphoe Shoot, I was sure it was a slash problem. =/
    – Wesley
    Sep 9, 2011 at 4:31

You can't map a network drive to an https connection pre Windows Vista, at least not with the Net command. This has to do with an issue with the WebDav mini redirecter. Please check the following: http://www.autohotkey.com/forum/topic44471.html


Please try

C:\>net use z: http://user:[email protected]/software

The other thing that I see is:

net use * z: https://mywebsite.com/software password /user:username
  • Those didn't work either.
    – Nixphoe
    Sep 8, 2011 at 21:36
  • Damnski. I'll see if I can make it work here...
    – gWaldo
    Sep 9, 2011 at 0:31

Have you checked out this Microsoft KB article? It might be worth a shot.

You may receive a “The network name cannot be found” error message when you use the fully qualified domain name to connect to a remote computer from a Windows Server 2003-based, Windows XP-based or Windows 2000-based computer

I would also recommend using Fiddler to snoop on the traffic as you issue the net use command. You might see something a bit more interesting than the WebDav System Error 67.

  • I saw that KB, I didn't think it was really related. But I gave it a shot. Both suggestions didn't work. I tried Fiddler, and it didn't pickup anything when I used net use.
    – Nixphoe
    Sep 8, 2011 at 21:55

Mmm. How about:

net use z: https://mywebsite.com:443/software/

Also, when you attempt to do 'net use z: http://mywebsite.com/software/' (point 5 of what hasnt worked) is port 80 active on your target server? Clearly this is an XP problem - can we isolate it to XP and HTTPS or is it XP and Webdav? Do your event logs show anything?

Also: Might the net use command be using the windows internet security settings for mapping the drive? You may need to place https://mywebsite.com in your trusted sites. Look in IE -> tools -> security, or your control panel.

  • I can hit both https: and http: from the XP machines in the browser. This is definitely an issue with XP and Webdav. The Microsoft fix doesn't seem to be cutting it. I've also tried the :443 at the end of it, as you suggested. No dice.
    – Nixphoe
    Sep 14, 2011 at 14:56

Webdav ON IIS: net use * http://WEBSITE/DavWWWRoot PASSWORD /user:USER@DOMAIN

if you use IIS the Root folder have this name DavWWWRoot , some client resolve automaticaly ( windows 10 and windows 7 ) but in other case you must specify (windows xp). This work form me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .