I've got some neworking issues with my sbs 2008 server. Basically if i try and access the server's shares via a unc path it takes a long time to resolve, but a mapped drive is quick (until i try to open a file then very often it can be slow).

This behaviour even happens on the machine itself if i try and access it's own shares via it's unc path e.g


Copying to it or from it once open is as fast as ever, and the behaviour is periodic - it sits for a while thinking then everything bursts into life and is quick, then after a while it is slow again.

Things to note:

1) I've no virus guard on it (uninstalled it when i started to have trouble). 2) It is fully patched up. 3) I've checked the switch by continuous pings and don't lose any. 4) I've tried disabling shadow copies with no effect. 5) No backups are running.


additional information

1) macs don't seem to have a problem with shares

2) exchange has issues - entourage says it has problems copying an email to sent folder on a mac

3)The server has a Broadcom BCM5708C NetXtreme II NIC

4) TCP chimeny is now off, as is checksum offload is off, large send off load is off. TOE is enabled on the card but can't be disabled unless i turn it on in windows first i think.

5) using the ip address doesn't help.

9 Answers 9


Are you using Symantec Enterprise Security 11? There is an issue with 2008 and server shares on older updated versions; not sure if this is your issue but something to look into if you are using symantec (I didn't see any statement about A/V software).


I noticed this problem on my first 2008 file server after about 20/30 users started using it. It got progressively slower then finally just gave up sharing files but everything else (RDP, etc.) worked fine. After ripping hair out I found it to be the A/V problem stated above.

  • we're using mr4 and i've uninstalled it from the server anyway. Jul 14, 2009 at 12:11
  • i had uninstalled it but not rebooted. After the reboot it was ok. Aug 24, 2009 at 10:53

Have you a Broadcom NIC in the server and is the TCP offload engine enabled? This is a configuration known to cause trouble, so it's certainly worth checking out and disabling the offload engine if required.

  • i do have that NIC and have that enabled i think. How do i turned it off? the set chmmney DISABLED command is unrecognised. Jun 24, 2009 at 13:34
  • A few steps here: support.microsoft.com/kb/951037 Jun 24, 2009 at 13:36
  • when i run netsh int tcp show global it says the tcp chimney is disabled. However on my dell open manage is says the network has TOE enabled. the ms site says it has to be enabled i both places to work but could it still affect it? Jun 24, 2009 at 13:51
  • rss is enabled. on the network adapter there are lots of settings - rss, ethernet@wirespeed, flowcontrol,ipv4 checksm offload, ipv large send offload, jumbot mtu, local admin address, priority and vlan. Any of these related? I can't see how to turn TOE off on the card Jun 24, 2009 at 13:55
  • Try checksum offload and large send offload first; these are functions which are normally performed by the protocol stack but which - when enabled - are performed by the adapter instead. Jun 24, 2009 at 14:05

What happens, if you use the IP address instead of the name:


Is this a Windows Domain and you are accidentally using external DNS servers, maybe of your internet provider - instead of your domain controller(s)?

  • it is a windows domain and the DNS server for clients and the server itself is the server's ip address. The external DNS of the isp is in the DNS server's forwarding servers. I assume that's correct? Jun 24, 2009 at 12:22
  • Okay, so this is not the issue.
    – splattne
    Jun 24, 2009 at 12:36
  • but using the ip address is quicker?
    – splattne
    Jun 24, 2009 at 12:37
  • When trying to open a file using the ip address instead of the servername i still get a message saying windows can't find the file. Jun 24, 2009 at 12:41
  • in terms of speed of access - it comes and goes but i have replicated the behaviour using ips. sometimes it's quick sometimes it's slow. Jun 24, 2009 at 12:43

My initial thought is that it's either a name resolution issue or an authentication issue. The mapped drive in both cases has already done both of these.

Things to try:

  1. Connect via IP \\Share or \\Share - is that any quicker
  2. Connect to \Server first, then once connected is \Server\Share any quicker?

If the first issue, ensure the client machines are using the internal DNS server as their primary server.

If the second issue check the event logs on the server for anything domain controller related.

  • the only domain controller related error is: The processing of Group Policy failed. Windows attempted to read the file \\contra.local\SysVol\contra.local\Policies\{9BB28F78-50AC-4BA3-8500-A833DD05D8DC}\gpt.ini from a domain controller Jun 24, 2009 at 12:25
  • when i click on that link it takes a while but eventually opens the ini in notepad. Jun 24, 2009 at 12:44
  • Group policy is unlikely to have anything to do with it, more likely it's indicative of the same issue. Jun 24, 2009 at 15:19
  • I agree with Joel here on his point that the issue is still the same with the mapped drive, you just don't "notice" that it was slow because the computer took care of making the connection already before you asked for it.
    – Matt
    Jun 24, 2009 at 16:12

I Had a similar issue and tried all of the above & more, but none worked until I turned off the windows 2008 Firewall, now the share is really nippy :)

NB: Our network firewall protects the win2008 system


One other thing came to my mind. Some weeks ago, there was this question here on ServerFault.com:

Disable Windows Server Network Locations

My problem is that sometimes some network adapters decide they are now on a public network. This completely activates the firewall, even for the "domain" networks. So net effect is that I reboot some machines, and then they never come back on the network until we KVM in and tell it that the network is private.

Maybe this is your problem too.


did you found it. What about smb 2.0 protocol? If you access a win2008 share from a winxp they agree for smb 1.0 on the other hand if you access with a winvista they should drive the smb 2.0 protocoll. Could this explain this behaviour. Ice


I had a similar problem when having machine1 IIS with it's homepage pointed to \machine2. Very slow transfers through the website. I turned off SMB2 as this page shows, and it fixed the problem.



I had this issue on UNC query from webservers to document servers in workgroup of both Windows 2008 and 2012 servers. First call of the day could take over 60 seconds, subsequent calls were about 200 mSecs. Solved the problem by disabling TCP/IPv6 on the internal NIC's.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .