The installation is a Windows 2008 R2 server with an Exchange 2010. I am trying to install BESX on it, for which a user account is needed to login on the domain controller and run the installer. I keep getting:

The User Profile Service failed the logon. User profile cannot be loaded.

Everytime I try to login, even after I add the "BESAdmin" account to either Administrators, Domain Controllers or both. I've even changed the Allow Local Login policy to even specifically include the account.

Another poster who had a similar problem with the same error message stated that this happens with new accounts (like in my case) or accounts that have no v2 profiles (?) yet. He self-answered that one should copy c:\users\default from another installation. I do not have that option, so I am really hoping for some other solution.

  • Just kicking it out there, but did you log on with the BESAdmin user to the server, like start an interactive desktop session... from which their profile directory will be copied from c:\users\default` to c:\users\besadmin`? Does besadmin have logon as service right? seems like a hyper-common question: google.com/…. also check out eventid.net's comments for the failure event. Also, check this sucker out: support.microsoft.com/kb/947215 – mbrownnyc Sep 9 '11 at 20:09
  • The problem was not specific to besadmin. Any new user could not login and failed with said error. I've tried many many suggestions, even those on SF, before posting. Disabling UAC seemed to help (for now). This seems to be an ultra common problem with many different causes. – adamo Sep 9 '11 at 20:20

Had the same problem. See http://social.technet.microsoft.com/Forums/windowsserver/en-US/95c8635c-76fa-47ff-a03c-a44d1e9a599b/server-2008r2-the-user-profile-service-failed-the-logon-user-profile-cannot-be-loaded?forum=winservergen. The solution listed on Microsoft Technet was to check that all privileges on files and folders in c:\users\default were correct. In my case I learned from the eventvwr that one obscure Visual Studio file had no privilege for read to Domain Users.


After some random surfing on the Net, an advice I followed was to run msconfig, disable UAC and reboot. I logged into the machine! Why this works, I do not know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.