i tried elgg on windows XP and it installed successfully but when i tried on fedora 12 it is not able to install. here is what happens i extracted the zip file for elgg in /var/www/html now when i use firefox to go to the url http://localhost/elgg- it asks me whether i want to open or save install.php ,but when i open it with a text editor or if i save it and then open it its an empty file. The size of file is 0 bytes. And when i use Konqueror to do the above it displays a timeout error instantly(at the moment i press enter).

i checked the error log of apache and it displays the following line

child pid 2147 exit signal Segmentation Fault(11)

I was able to install elgg 1.7.11 on fedora successfully,also i am able to run other php files nicely.I wonder what can go wrong *because elgg installs successfully in windows XP. (Note:I have the appropriate permissions for reading writing and executing scripts in the elgg directory)

UPDATE: i tried strace php install.php and i got a long trace of which i am only showing the last few lines

mmap2(NULL, 11905, PROT_READ, MAP_SHARED, 3, 0) = 0xb77cb000
munmap(0xb77cb000, 11905)               = 0
close(3)                                = 0
getdents(4, /* 0 entries */, 32768)     = 0
time(NULL)                              = 1317422887

access("/usr/share/zoneinfo/Asia/Calcutta", R_OK) = 0

access("/var/www/html/elgg-", R_OK) = -1 ENOENT (No such file or directory)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV (core dumped) +++
Segmentation fault (core dumped)

Now any idea why there is this segmentation fault? I have read that infinite recursive function calls can cause seg faults but if that was the problem it wouldnt have run on windows. If i try to include a lot of files with include or require or require_once can it lead to php causing a segmentation fault?

  • This sounds like there may be an issue with mod_php. Can you try creating a test PHP file with the contents, <?php phpinfo(); ?>? When you access it from your browser, what happens? – Andrew M. Sep 12 '11 at 4:20
  • @Redmumba yes i can create other php files and they are working correctly.As my question says i was able to successfully install elgg 1.7.11. – lovesh Sep 14 '11 at 9:53
  • My bad, I am blind! :) Just out of curiosity, have you tried doing something like executing it from the command line (i.e., php install.php)? Also, have you enabled PHP logging in your php.ini? – Andrew M. Sep 15 '11 at 21:43
  • @Redmumba yes i have enabled logging and updated my question to show the errors.Thanks – lovesh Sep 20 '11 at 18:13
  • The superglobal notices have nothing to do with the segfault; the $_SERVER array is unavailable when running the CLI. Which database engine are you using? – xofer Sep 20 '11 at 18:22

There was a bug in my php version. Updating to a later version solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.