We've just moved to Server 2008 R2, and I have setup folder redirection for our users using group policy.

All folders redirect and work as expected:

  • users My documents are redirected.
  • users can create and delete folders and documents within redirected folders.
  • users can only access their own redirected folders
  • Administrators can access users redirected folders

The issue i'm having is moving the users backed-up documents from our old server into the newly redirected folders. When I copy or move the files, the files do not get the expected users inherited permissions, and the user cannot access them.

Now I know I can re-apply the permissions on each users redirected folder after copying the files, but this will be a pain to do for every user.

My folder that contains the redirected folders has the following permissions:

Share Permissions:

  • Everyone - Full Control

NTFS Permission:

  • Creator Ownder - Full Control - Subfolders and Files only
  • SYSTEM - Full Control - This Folder, subfolders and files
  • Administrators - Full Control - This Folder, subfolders and files
  • Users - Special - This Folder only

The Users permissions are

  • Traverse folder / execute file
  • List folder /read data
  • Read attributes
  • Read extended attributes
  • create folders / append data
  • read permissions
  • Are you sure that inheritance is set at the user folder level? From what you're saying, there's no reason that it wouldn't inherit otherwise. – MDMarra Sep 13 '11 at 1:27

A suggestion or two..... try using robocopy.. and tell it to ignore the security /COPY:DAT this "should" allow the files to be copied and inherit the permissions based on the parent folders. The problem when I did this was the the previous admin had set permissions for the user on the child folders and I ended up going back and having to reset them by hand.

Another option is to script it. If you have tons of users to move and know you have to reset the ACLs, icacls would be one way to go. Have teh script copy over the users data and then have the script reset the permissions for you.

But more than likely, you'll need to abandon the GUI for a bit to make this easier on yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.