I have three windows boxes that are connected to a linux box on my network in various ways (one's local to the network, one is a laptop and may or may not be local, and the other is my work desktop). I'm currently making use of git to syncronize most of my stuff between the boxes (using the Linux box as the server) and it works like a champ.

Now, however, I'd also like to add my MP3 collection (12 gigs) to be efficiently synchronized between boxes. I initially thought I could use git for this, but it looks like rsync would be a better choice since I don't really need all the historical stuff. Since all my existing management scripts run under git bash (instead of cygwin), I'd like to be able to use it from git bash (MINGW32 is what it says in the title bar of the window). Can I just download it in Cygwin and copy it over or is there a better way to approach it? The Linux box is running the latest version of Ubuntu Server edition - do I need to do anything to it to enable rsync to work correctly on it?

I realize I'm probably doing this in a slightly harder way than is needed, but I'm also kind of using this as an exercise in improving my commandline skills. Any suggestions?

I can use rsync from my cygwin shell, but not from msysgit. I tried copying rsync.exe from cygwin's bin folder over to msysgit's bin folder, but it still isn't finding it. Is there some other step I need to do to install it there? It's strange that I'm getting an error that it can't find the file, instead of giving me an error that one of the file's dependencies is missing.


As of now (9/7/2017) it is extremely easy to manually add rsync support to the Git for Windows environment without even having to resort to running the Git for Windows SDK.

I stumbled across this post and didn't think it could really be that easy given all the alternatives, but it really is. All you need to do is grab the rsync package from the MSYS2 Package repository and extract the rsync.exe file into C:\Program Files\Git\usr\bin. One and done. It works.

If you need help extracting rsync.exe from the rsync package (which is in tar.xz format), you can either use a compression utility like 7zip or do it directly within the Git for Windows bash environment like so:

cd /c/downloaded_location
tar -xvf rsync.pkg.tar.xz usr/bin/rsync.exe --strip-components=2

This gives you the rsync.exe file in the downloaded location (adjust the package name accordingly). In light of Windows permissions issues I won't try to give specific commands on getting the exe into the C:\Program Files\Git\usr\bin folder. You can copy it via an explorer GUI or via an elevated command line utility (and yes, it will require admin level permissions to copy something into the Program Files folders).

If you want to also use Pageant authentication with rsync over ssh, the ssh-pageant binary is already installed in Git for Windows and all you need to do is add a small bit to your ~/.bashrc or ~/.bash_profile file (see ssh-pageant usage section and Git for Windows wiki). I've modified it specifically for use with the Git for Windows environment and enhanced it with some detection for a missing socket file:

# ssh-pageant allows use of the PuTTY authentication agent (Pageant)
SSH_PAGEANT="$(command -v ssh-pageant)"
if [ -S "$SSH_AUTH_SOCK" ]; then
if [ -x "$SSH_PAGEANT" ]; then
  eval $("$SSH_PAGEANT" -qra "$PAGEANT_SOCK")

I can't speak to how other utilities might or might not work by manually installing them this way, but rsync appears to work just fine. Hopefully that repo will stay and continue to be updated--I'd think so because it's hosted at the official MSYS2 site.

  • 1
    thank you sir, downloading and it works .. who would have known... – pscheit Nov 18 '17 at 7:46
  • Problem. There is no rsync.exe only various versions of rsync in.pkg.tar.xz formats. That might be OK, except that I cannot install apt-get install xz-utils (sudo apt-get install xz-utils) because I can neither install sudo OR apt-get to Git Bash for Windows :-( and thus thus cannot install xz-utils. Is there any way around this? Is there a newer link where I can get rsync.exe, or some way I can get Git Bash to uncompress this .xz file? – SherylHohman Jul 23 '19 at 14:09
  • Actually, it seems to be more a permissions problem. When I tar -xf rsync-3.1.3-1-x86_64.pkg.tar.xz, I get a bunch of messages stating: Cannot open: Permission denied, Cannot mkdir: Permission denied, Cannot mkdir: No such file or directory and Cannot open: No such file or directory for various files/directories. Maybe Git Bash already knows how to uncompress xz files? But cannot b/e of permissions? I cannot use or install sudo. to Git Bash. – SherylHohman Jul 23 '19 at 14:17
  • 1
    In my case i had to put rsync.exe in c:\Program Files\Git\mingw64\bin\ – kanlukasz Feb 15 '20 at 14:31
  • 2
    An update: since 2020, there's one more step required first. The rsync packages in that repo are no longer in .tar.xz format but rather .tar.zst, and Git for Windows out of the box doesn't understand that format. Happily, it's enough to first install zstd: download zstd-….pkg.tar.xz from that same repository, unpack and install that, and then tar -xvf is able to handle the rsync.pkg.tar.zst file. – Greg Price Mar 16 at 21:19

I know the question isn't "Using rsync for MSYS", but I think mentioning this is relevant:

"MinGW Shell" (formerly best known as "MSYS (Basic System)") does indeed have rsync. I'm using that shell/system as often as possible since it's much smaller than Cygwin. (I'm probably the only one that cares about file sizes these days.)

"Git for Windows" / "Git Bash" could easily add rsync since it based on MinGW/MSYS and it has been mentioned on the mailing list earlier.

PS! If your MinGW Shell doesn't have rsync, just run "mingw-get install msys-rsync" to add it.

Updated 25th of March 2016:

Git for Windows now uses MSYS2. And MSYS2 uses "pacman", not "mingw-get", to install packages. Unfortunately, "Git for Windows" doesn't include pacman ... There are two options:

  1. Install the Git for Windows SDK (which includes pacman).
  2. Install Git inside MSYS2.

The last option is my favorite, but it's not streamlined yet so the first option is probably easier. Hopefully, it will be fixed.

PS! I haven't played much with MSYS2 / pacman, but it seems very promising.

Updated 7th of August 2019:

If you are using Git for Windows (Git Bash) it's much better to just grab the rsync package from the MSYS2 Package repository, as is described in the answer above.

  • sadly, in Git Bash: $ mingw-get bash: mingw-get: command not found – Hendy Irawan Mar 24 '16 at 17:06
  • Yes, it's a bit sad. Look at my updated answer above - still sad, but the situation has improved. – hansfn Mar 25 '16 at 8:40
  • I went for the second option and I ended up with a 2.17GB folder, but everything work like a charm. I installed rsync by using pacman -S rsync. In the past I used CygWin but I think MSYS2 is awesome, I don't have to run a gui to install extra packages. – Edenshaw Jun 21 '16 at 16:39
  • The bug report listed in this answer has since been closed as "unfixable" - however, I have created a pull request to have rsync included with Git for Windows. – Scott Stevens Feb 14 '17 at 12:54
  • Any links on how to do either option 1 or option 2? I think I have Git for Windows SDK. Dunno. But assuming I do, or can get it.. what then? If not, I have no idea what it even means to install Git inside MSYS2. Does that mean I need to delete my current Git install. Will I loose anything, like settings or functionality if I do so. Will nay links break? – SherylHohman Jul 23 '19 at 14:22

I assume by git bash you really mean msysgit, aka "git for windows." The Start Menu option is git bash, which explains the name you used..

First, you are correct in dismissing git as an option here. One of the things git does not do well is handling binary files--and you'd end up with a huge, bloated repository. Additionally, since you won't be handling changes, using the overhead of git strikes me as overkill.

Secondly, it sounds like the question you're actually asking is, "Can I use rsync from msysgit/Windows?" The short answer is, not out of the box. msysgit is really just the Windows command line in terms of form and function. That being said, you have two options: download a third-party tool to enable rsync on your Windows machine (Stack Overflow: Rsync for Windows), or just use cygwin. Really, they have the same outcome--so its up to you to decide which ones work better.

  • I can use rsync from my cygwin shell, but not from msysgit. I tried copying rsync.exe from cygwin's bin folder over to msysgit's bin folder, but it still isn't finding it. Is there some other step I need to do to install it there? It's strange that I'm getting an error that it can't find the file, instead of giving me an error that one of the file's dependencies is missing. Thanks, Will – Will Gant Sep 13 '11 at 1:31
  • This simply isn't possible. cygwin sets up a GNU-based environment, including Linux-like libraries, configs, etc.. msysgit is the Windows command line, which supports Windows executables. What's likely happening is, its not even able to detect the file as executable. Simply put, cygwin and msysgit are not even remotely compatible. – Andrew M. Sep 13 '11 at 2:08
  • It is possibly but hacky. Copy cygiconv-2.dll, cygwin1.dll and rsync.exe from Cygwin to your msysgit path. Nothing else (especially not ssh.exe). The problem is usually an incompatibility between Git SSH and Cygwin/rsync SSH. Try to keep the same version. You'll still have issues with the /cygdrive/ but there I've no solution except a cd. – Wernight Jun 18 '12 at 23:47

Update January 2021:

Since mysys2 is now using zstd you need to download more than just rsync to get this working. As well as rsync-3.2.3-1-x86_64.pkg you also need to download and copy libzstd-1.4.8-1-x86_64.pkg libxxhash-0.8.0-1-x86_64.pkg and for completeness I also downloaded zstd-1.4.8-1-x86_64.pkg

and 7-zip doesn't do the job of extracting the .zst compressed files wither, so I had to get PeaZip.

  • ..except that it seems to be unusably slow! – PhilipSargent Jan 3 at 17:40
  • Aha. I have a network drive mounted as P: so I can rsync to it either as /p/mycopyfolder/ or The /P/ method is unusably slow whereas explicitly using the IP address is as fast as I would expect. Interestingly I get exactly the same effect when using cygwin64 instead of mysys2 : the IP address version is fast but /cygdrive/p/ is unusably slow. msys2: rsync version 3.2.4dev protocol version 31 cygwin64: rsync version 3.2.3 protocol version 31 – PhilipSargent Jan 3 at 23:37
  • Thank you for this 2021 update! To unpack the .zst files you could also install 7-Zip Zstandard Edition And this link explains how you can run rsync directly from a command prompt window. – FlexMcMurphy Mar 21 at 3:41

For what it's worth, I was having similar problems getting cwRsync to work in msysgit when dropped into the bin path, but after trying lots of different things eventually found that simply updating to the latest version (2.10.2) of Git for Windows fixed the issue.


rsync is a great for unidirectional sync. You can either run rsync under cygwin, or for Windows there is also Deltacopy

If you wanted to have bidirectional sync, then take a look at unison

For a cross platform directory synchronisation tool, there is syncthing which runs on most platforms.

  • unison is great, but you have to install it on server - like 90% of servers are rsync ready. And OP asked for rsync – pscheit Nov 18 '17 at 7:50
  • the OP asked about rsync, but the what the OP was trying to achieve was "to be efficiently synchronized between boxes", and unison is available in most repos... – shouldbeq931 Nov 19 '17 at 11:20
  • Looks like DeltaCopy is not available for Windows 10. May no longer be maintained? – SherylHohman Jul 23 '19 at 17:48
  • It's difficult to tell if Unison works on Windows 10. Hasn't had an update in a long while. There is no mention of what versions of Windows OS that this software supports. There are several issues re: Windows 10 github.com/bcpierce00/unison/… – SherylHohman Jul 23 '19 at 17:54
  • As a cross platform tool to keep a directory structure in sync these days, I'd suggest syncthing syncthing.net However in 2011.... – shouldbeq931 Jul 24 '19 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.