I recently setup a Windows Server 2003 R2 machine to be a domain controller, kind of to experiment with that whole concept. Originally, it was sharing a printer attached to it to my home's workgroup, although it had been awhile since I had used it.

Now, I'm trying to access that printer from a computer that's in the workgroup, but not the domain. I'm trying to re-add it on this computer (which is running Windows Vista Ultimate x64 SP2), and I can't seem to log onto the "Everyone" builtin account like I used to.

I'm assuming that this is some sort of security policy that was brought in by the Domain Controller role, although I can't seem to fix it.

I went into the Default Domain Policy and changed the Allow log on locally policy, and added the Administrators and Everyone groups/users, although I still can't log on from the Vista computer, saying that I'm giving an incorrect Username/password. (For the username, I'm specifying the machine name of the server, then a back slash, and then "Everyone".)

Can anyone tell me what else it is that I have to do?

  • Whoops, solved it myself... Posting answer in 7 hours. – TGP1994 Sep 13 '11 at 22:43

Nevermind, fixed it my self.

Turns out I have to use the Guest account instead. Since it's disabled by default, I had to change the security policy(ies) to enable it. For some reason, on my computer, I have to change two identical policies in different editors to achieve anything.

So, I went into Domain Controller Security Policy and Domain Security Policy (anyone care to explain why I need to change both?), then I went to Local Policies > Security Options > Accounts: Guest account status, I checked the check box, and hit Enable. Then after applying, I was able to access the printer.

Hope this helps. I'm still confused as to why two identical security policies needed to be changed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.