1

The server with i7 CPU (Intel(R) Core(TM) i7 CPU 950 @ 3.07GHz) under linux kernel 3.0.0 (3.0.0-10-server) generally works properly, but when it is put under heavy load - it overheats (as shown by "sensors" program) and locks up (with bunch "CPU temperature too high" messages on the console).

I have cpufreqd daemon running, which dutifully throttles CPU speed from 3060000 Hz to 1596000 Hz. Yet this is not enough to reduce CPU temperature under heavy load.

I suspect that there is fan/heatsink/thermal paste problem somewhere, which I am going to check on first opportunity.

Is there anything else I can do to slow down the CPU to prevent it from overheating?

1 Answer 1

4

Yes, don't load the server up. But seriously, if you have a CPU thermal issue, it's best to take care of it now, and not later. It's not very good for (sensitive) electronics to be continually overheated and put back to work.

I'm not familiar with cpufreqd, does it throttle frequency based on current load? If so, it may be scaling frequency back up when the load goes higher. Maybe try setting the most conservative CPU governor? You can check which scaling governors you have by

cat /sys/devices/system/cpu/cpu#/cpufreq/scaling_available_governors

You can see which governor you are currently running by

cat /sys/devices/system/cpu/cpu#/cpufreq/scaling_governor

The lowest frequency setting governor should be "conservative". You can change to this by

echo conservative > /sys/devices/system/cpu/cpu#/cpufreq/scaling_governor

You will have to do this for each CPU / core, so, do an

ls /sys/devices/system/cpu/

But really, fixing the (hardware) problem is the best way to go...

1
  • 1
    +1 for "stop using it." Sep 14, 2011 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.