I have a Windows Server 2003 cluster of 2 nodes in an active-passive configuration. I can ping both nodes, rdp and access their unc shares.

I also have an alias, which directs to a cluster IP set in one of the cluster groups for SQL. (I'm not the SQL administrator and have had only a little exposure to it). This alias responds to pings and RDP goes to the active node, which works correctly.

However I can't access the UNC shares for that alias. The DNS record is obviously correct as it's handling ping and RDP ok.

What's interesting is that I can RDP to the alias (which in turn is the active node) and then try accessing the unc share of the \localhost or \ fails also.

I've looked at other questions on here before opening the this question and checked recent updates etc. But I feel these don't relate to my issue.

This has worked for quite a while and the only thing that has changed is that we have had to bring the whole data center down recently for much needed power maintenance work. Which makes me question perhaps a service didn't start.

Also whats worth mentioning is, is that I would have liked to failover to the passive node and see if the problem persists on that but I have a rather small time frame to take the server down which is early in the morning so I'm trying to avoid that if I can.


My problem appears to be that all my groups, "Cluster Group" and "SQL Group" can be pinged and RDP'd by their cluster name and cluster IP, however I cannot access any UNC share on the cluster IP or name of any of my groups.

If I browse to \SQLGroupClusterName from any networked machine I get "The network path was not found" error.

If I rdp to SQLGroupClusterName (which works) then browse to \SQLGroupClusterName from QLGroupClusterName I get the same error message.

  • Just so I am clear on this. If from another machine you do \\x.x.x.x\sharename (obviously with the IP of the active node in there) does it work properly?
    – Nate
    Sep 21, 2011 at 21:12
  • Yes it works perfectly
    – stead1984
    Sep 22, 2011 at 7:23

2 Answers 2


Is this to have a file share on the SQL cluster? If you share a drive on node1 then do a failover to node2 the file share will go away unless you define it as a cluster service. There is a resource type simply called File Share in cluster administrator, this way the active node will have the file share (don't use admin file shares). Make this depend on the physical disk and the cluster IP address.

  • No this is just a SQL Database cluster, it's just that our DBA needs access to the hidden shares on the SQL group cluster name.
    – stead1984
    Sep 16, 2011 at 9:20
  • Again, don't use the admin shares (IPC$, C$, D$ etc). Share what you actually need as cluster resources.
    – HampusLi
    Sep 16, 2011 at 10:07
  • @ HampusLi Sorry I get what you are saying. The file share is a resource set in Cluster Administrator. So that it would failover onto whichever node was the active node. The file share has been accessible up until about a week ago.
    – stead1984
    Sep 16, 2011 at 14:39

Bearing in mind the following two points:

  1. If you are using a file share resource in the cluster this shouldn't be needed.
  2. From your description it should be working correctly.

Here is a solution:

On 2003 connecting to a share with a different dns alias then the server name (otherwise known as multihoming) requires you to disable the DisableStrictNameChecking registry entry. It is supposedly a "Feature" of SMB.

You can reference the complete instructions on making the change here: KB281308

  • The alias redirects to the cluster name and that cluster name and any other cluster resources should be owned by the active node.
    – stead1984
    Sep 27, 2011 at 10:19
  • If you have manually created the DNS cname then you need to make the above change for it to work on 2003
    – Nate
    Sep 27, 2011 at 22:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .