12

I'm having fan speeds and noise level issues from my most recent batch of HP ProLiant DL380 G7 servers. Most of the systems are nearly silent with low fan speeds (as reported by hplog -f). The majority of systems causing issues are running an operating system that cannot accommodate the HP Insight Management agents or drivers (NexentaStor 3.1). I also have a few CentOS servers running the HP drivers that have the same issue. Some of these systems have 2 or more PCIe cards installed.

Is there any way to force a lower fan speed on these servers? I've seen the advisory on the BIOS cooling option. I'm more curious about the random nature of the issue and if there's any means to control this via software.

  • They're in a proper server room, right? If so, what's the big deal? – EEAA Sep 15 '11 at 23:53
  • Some go to client sites, where the temps are regulated in the server rooms, but the noise is noticeable. Having 20 servers that are silent and 5 that are noticeably louder makes me curious. – ewwhite Sep 15 '11 at 23:57
  • Sure. I wish I knew the answer to this, but I don't. Fortunately all of mine are locked away well out of hearing distance. :) – EEAA Sep 15 '11 at 23:58
  • My ProLiant DL360 G7 seems to rev its fans based on current and anticipated CPU usage, not on temperature, so it'll blast even when it's cool sometimes. I apt-get install some small library, and it immediately revs the fans up for a second like it thinks I'm about to fire up 100% CPU tasks on all cores. – sudo Jun 26 '16 at 17:29
5

You can set a power policy via the iLO configuration. By setting the CPU power modes to lower settings, the fans may also spin down accordingly.

  • The ILO power policies didn't have an impact on fan speed. I did try working with the CPU power modes, but no change. The major factor seems to be related to PCIe riser population. – ewwhite Sep 19 '11 at 15:37
5

The issue here is related to PCIe riser population. I worked with zero installed cards to a fully-populated enclosure. At around 3 installed cards, the fan speeds settled at higher levels. According to HP, this is by design. It also depends on the types of cards installed, and their power draw. My worst systems had legacy PCI-X risers installed with 5V cards or were running 4 or 5 HBAs and a PCIe flash device.

Edit: Newer BIOS revisions on the G6 tower models (ML350/370) now include a "reduced acoustics" mode that lowers fan speed and noise output considerably.

1

I found that the firmware update (HP Broadcom NX1 Online Firmware Upgrade Utility for Windows Server x64 Editions (cp025019) in the latest support pack was causing the fans to keep ramping up and down. Very annoying. Removed that "upgrade" and back to normal. -My 2cents

  • Had exactly the same problem.... had to downgrade again – mario.schlipf Jan 6 '16 at 18:30
1

Had the same problem here on Proliant ML 110 G5. As Daniel shared i found it is caused by the firmware update (HP Broadcom NX1 Online Firmware Upgrade Utility for Windows Server x64 Editions. But instead of removing that update, the fan problem got solved automatically after flashing BIOS with the latest firmware upgrade for management (Firmware Upgrade for HP ProliantML 115 G5\ML 150G5\DL 120 G5 Lights-Out 100 Remote Management (or USB KeyMedia))(SP49103)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.