Is it possible to set up a VPN server on a machine running Server 2008 R2, when you only have one NIC? I'm trying to connect to my server with the following setup

Windows 7 -> Internet -> Linksys WRT54G -> Server 2008 VPN

It seems no matter what I try I just can't establish a connection to the server, receiving a variety of 800 and 806 error messages depending on the type of VPN connection it is trying to establish.

I've tried forwarding port 1723 to my server, and have verified that all of the VPN passthrough options are enabled. On my server, the firewall shows port 1723 (PPTP-In) is opened and enabled. Of course, that may be misleading as I've already run into an issue where port 21 was showing as enabled, but it really wasn't open until I ran a command from a command prompt running as Administrator.

This is really making me pull my hair out, I HATE having to leave 3389 open for RDP, or using FTP externally for remote access to files. If anyone has any advice on how I can get this done I would greatly appreciate it.

UPDATE: Even by placing my server in the DMZ, the PPTP connection does not work. Does this mean that the problem is related to my server configuration, and not my router firewall? Is there any additional logging or debugging I can do to more specifically locate the point of failure?

  • As a test, connect to the VPN from a computer on the same LAN as the server. If that works then that means you've got a firewall/network problem. If it doesn't work then that means you've got a server problem. – joeqwerty Sep 17 '11 at 18:56
  • I'm not sure I quite understand the downvotes, perhaps an explanation? – mclark1129 Sep 26 '11 at 5:46

GRE is not always forwarded by routers, this is one of the benefits of using a SSL VPN as it is more compatible.

Example of SSL VPN: http://openvpn.net/

PPTP uses a TCP connection on port 1723 which you have already routed to your server, then over that a GRE connection is negotiated for the routing.

Make sure any PPTP server on the router is disabled to make sure it is not receiving the GRE traffic instead of forwarding it.

|improve this answer|||||
  • I'm going with an SSTP VPN built into SBS 2011, which I am having some more progress with. Now my only hurdle is to get past the certificate validation issues I'm having. – mclark1129 Sep 25 '11 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.