I created a virtual machine and installed Debian 6 on it, and then copied the hard drive to be used by another virtual machine. For the newly copied virtual machine, I changed the IP address, hostname and MAC address. Now, whenever I start up the machine, it comes up with these failure messages:
"Starting NFS Common Utilities: statd failed!"
"startpar: service(s) returned failure: nfs-common ... failed!"
"ALERT: exim paniclog /var/log/exim4/paniclog has -non-zero size, mail system possibly broken ... failed!"

I know this is a rather common issue but I haven't yet found any answers to the problem. I've already tried uninstalling nfs-common and portmap, then re-installing nfs-common and rpcbind (I read that I should install that instead of portmap). This did not wield success. Could someone please tell me what steps I can take to find out what the problem is?

2 Answers 2

  1. man statd
  2. /FILES
  3. Start reading.

First guess: you still have the old hostname floating around in a couple of configuration files. I'd check for that first:

  1. find /etc /var -type f | xargs fgrep (whatever your old hostname was)
  • Thanks for the reply. I tried typing in that second command and was greeted with a lot of log files containing that old hostname. I also read the statd man file, but couldn't see how that would help.... Sorry. Could you maybe tell me how I can sift through all the log files and see only the config files? Thanks!
    – Miss M
    Sep 20, 2011 at 1:59
  • Please disregard previous comment if it is still displaying. I tried deleting it, but it wouldn't delete.
    – Miss M
    Sep 20, 2011 at 6:13
  • What did you try to delete?? Yes, logs are usually in /var/log so you may want to replace /var with something more specific. Please don't type in commands or delete files without understanding what they do - they all have documentation, e.g. man find gives you the explanation for the find command. Sep 20, 2011 at 10:51
  • I tried to delete my previous comment as I had resolved the issue. Thanks for your help and sorry for my slow response!
    – Miss M
    Sep 27, 2011 at 7:36
  • Never mind ... good to know that your issue is resolved! Sep 27, 2011 at 12:22

Any logs of nfs and portmap? syslog, dmesg? Also you can add set -x in the beginning of init script and run it manually, to see when and why it fails.

  • I tried set -x but that didn't do anything. However, I did try bash -x but that just bombarded me with bits of code such as "NEED_GSSD=no" and "log_progress_msg statd". How do I access the logs for NFS? And for portmap?
    – Miss M
    Sep 20, 2011 at 2:03
  • run dpkg-query -L <package> to see, if there are log files for that package in /var/log. If no, then all messages are logged to syslog, which by default in Debian and Ubuntu resides in /var/log/syslog. Run tailf /var/log/syslog, restart statd, portmap, see what messages do appear. Also you can change service start options in /etc/default/<service name>, according to it's manpage, to achieve more verbose debugging output Sep 20, 2011 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.