I have a git over http using apache+webdav, autenticating on a ldap directory.

It is working ok for most users, but since last friday (FUN FUN FUN!!! just kidding), when one particular client tries to push to the server, his client gets in a loop, and none of the other clients can push, although they can pull.

To solve this, a have to stop apache, remove the DavLockDB file, create it again and start apache again.

This will work until this client tries to push again.

This is what i already have tried:

  • update the client software (tortoiseGIT)
  • check the client clock
  • check client user permissions (client can authenticate against ldap and pull code from git)
  • check client network permissions (client is able to access the apache directory)

Other infos: client can't push in any existing project, but can push in a newly created test project.

If anyone needs more info to help me with this, its just ask =D


It was a client problem after all. Although i had already reinstalled the client, i did it again, but also used a registry cleaner tool between installs. It's solved now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.