I'm recently installed Oracle 11g on a Windows Server 2008 box and although the database appears to work just fine when I load up the Enterprise Manager in Firefox it tells me 'Agent Unreachable'.

From what I understand (I previously have only used MS SQL Server) this usually means there's a problem with the monitoring agent. I ran the following command and this is the output:

C:\Users\Administrator>emctl status agent
Oracle Enterprise Manager 11g Database Control Release
Copyright (c) 1996, 2010 Oracle Corporation.  All rights reserved.
Agent Version     :
OMS Version       :
Protocol Version  :
Agent Home        : E:\app\Administrator\11.2.0\dbhome_1\server_sid
Agent binaries    : E:\app\Administrator\11.2.0\dbhome_1
Agent Process ID  : 2184
Agent URL         : https://server:3938/emd/main
Repository URL    : https://server:1158/em/upload/
Started at        : 2011-09-20 20:12:47
Started by user   : SYSTEM
Last Reload       : 2011-09-20 20:15:05
Last successful upload                       : 2011-09-20 20:15:11
Total Megabytes of XML files uploaded so far :     7.85
Number of XML files pending upload           :        0
Size of XML files pending upload(MB)         :     0.00
Available disk space on upload filesystem    :   -48.86%
Data channel upload directory                : E:/app/Administrator/11.2.0/dbhome_1/server_sid/sysman/recv
Collection Status                            : Disabled by Upload Manager
Last successful heartbeat to OMS             : 2011-09-20 20:30:37
Agent is Running and Ready

I noticed here that the available disk space appears to be negative. There is plenty (3.4 TB) of space on the disk that Oracle is installed in but I'm not sure if it's searching a different path (none of the other disks are even halfway full). To further confirm the issue when I run the 'upload' command:

C:\Users\Administrator>emctl upload
Oracle Enterprise Manager 11g Database Control Release
Copyright (c) 1996, 2010 Oracle Corporation.  All rights reserved.
EMD upload error: Upload was successful but collections currently disabled - disk full

Has anyone seen this problem before, if not, are there some thing I could play with that might help?


I just got into the same trouble.

In fact, this is definitely a bug in OEM. In my case, the amount of space on the filesystem that oracle was using was 4.5T and the free space was 3.77T. Something was definitely overflowing, but since this was a Solaris 11 on a zfs filesystem, I did this simple trick: I created the separate zfs dataset, set it's refquota to 2GB, mounted it in the ${ORACLE_HOME}/hostname_${ORACLE_SID}/sysman/emd/upload, et voila ! It started seeing the correct free space and started uploading.

I have no idea so far about what I should do on Linux, wich doesn't have a production-ready zfs.

  • Yeah, on Linux one could create a separate extX fs, at least on an memory-device (if things turned that bad), just for uploading. Should work. – drookie Jun 23 '13 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.