6

For the life of me I cannot figure out how to remove an iSCSI target (Dell Equallogic SAN) from a Windows Server 2003 box. The volume shows up in Windows as drive letter Y.

Using the iSCSI initiator, I can remove the Target Portal, but cannot remove the Target itself.

Can someone give me some guidance on this?

I've gone as far as setting the volume offline in the Dell SAN management tool, and even permanently deleted the volume. The Target no longer shows up in the iSCSI Initiator properties, but the drive letter is still there under My Computer. And now Windows is throwing delayed write errors for that drive.

There must be a proper way to successfully remove an attached Target.

  • 1
    So far, this is the best I can find: netguy.org/wordpress/?p=295. I've also use a command like mountvol x:\ /d to dismount the drive. It does seem like there should be a better solution. – flickerfly Dec 26 '12 at 19:02
  • Try restarting the machine once and check. I faced similar issues during VHD disk mount and restarting the machine fixed my issue. hope the same do the trick for you – vembutech Oct 23 '14 at 20:07
2

It is strongly recommended before you remove an iSCSI target, you should make the disk offline in Disk management and then disconnect the target in iSCSI initiator window. To make it disappear in iSCSI initiator, you should remove the portal and favorite list.

0

Essentially the solution in the link from @flickerfly's is to use diskpart to remove the volume, which in turn makes the drive letter unavailable. This leads me to wonder if simply removing the drive letter with Computer Management >> Storage >> ... >> Change Drive Letter and Path would accomplish the same.

0

Well I had the same issue, there's no offline in 2003 server. But when right-click the disk and choose properties, under Device usage, I could switch it from "Use this device (enable)" to "Do not use this device (disable)".

To make it work, make sure the disk isn't being used, turn of all file shares etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.