0

I'm trying to install php 5.1.2 on a CentOS 6 server (for grandfathering in old websites).

I downloaded an RPM file ( php-5.1.2-5.x86_64.rpm ), but when I use:

yum install php-5.1.2-5.x86_64.rpm

I get the following error:

Error: Package: php-5.1.2-5.x86_64 (/php-5.1.2-5.x86_64) Requires: libcurl.so.3()(64bit)

I have tried several things including the following:

ln -s /usr/lib64/libcurl.so.4 /usr/lib64/libcurl.so.3 (To make it symlink to the newer version)

Downloaded curl-7.15.5-2.1.el5_3.5.x86_64.rpm and took the libcurl.so.3 out of the rpm and placed it in /usr/lib64/libcurl.so.3 with the same permissions as libcurl.so.4.

Nothing has worked. Any ideas?

4 Answers 4

1

have you tried to install libcurl.x86_64 and libcurl-devel.x86_64?

1
  • I already had libcurl.x86_64 installed, I installed libcurl-devel.x86_64 after reading your question. It had no effect though :( Commented Sep 22, 2011 at 13:16
1

Not sure if it'll help, but I just had the exact same issue and I found that I accidentally installed a repo for CentOS 5, instead of 6. You might want to check your repos

1
  • I found I had a similar issue with my repos. Fixed, ran update then re-ran the install and the error did not recur. Upvoted. Commented Apr 16, 2013 at 5:45
1

You can't just symlink to a different library version, the versioning is there specifically because different versions are incompatible.

You need to find or build the package for CentOS 6 so that it uses the appropriate libraries.

0

This issue will happen with other package installs not just php 5.1.2.

In my case I investigated Marc DiBlasi's solution and brought the repos on the problem machine in alignment with the other servers and run update.

When issues like this occur it would be a small thing to check the quality of your repo configuration.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .