We had HP DL360G4p with Windows 2008 R2 which was broken a few days ago. I setup VM on ESX4 because we don't have extra same hardware and recover from WindowsServerBackup image. The recovery looks okay, but it shows BSOD with Stop error 0x0000007b on boot.

Googling around the web, it looks like the issue on driver of HP SmartArray 6i but I'm not sure how to solve this. I did renaming driver file, HpSAMD.sys to other so that I will not be loaded at startup, change the registry for HpSAMD service to disable (Start:0->4), but all doesn't fix so far.

I understand it's not supported scenario to use WindowsServerBackup image, but it's difficult to get the same HW only for recovering and I really appreciate any help to solve this. I'm wondering why R2 doesn't work while it have been possible before R2...


-- found solution! --

  1. Launch recovery mode. (You'll see option after leaving it fail to boot then reboot automatically)
  2. Select Keyboard, enter password as needed.
  3. Launch Command Prompt.
  4. Run regedit.
  5. Select HKEY_LOCAL_MACHINE, then select File/Load Hive from Menu.
  6. Navigate to :\Windows\System32\Config\SYSTEM, name it as 'HKLM', for example. is typically D:.
  7. find key HKEY_LOCAL_MACHINE/HKLM/System/CurrentControlSet001/Services/LSI_SAS (my VM is configured as LSILogic SAS mode)
  8. Change Start to 0
  9. Select HKEY_LOCAL_MACHINE/HKLM, then select File/Unload Hive from Menu.
  10. reboot.

2 Answers 2


I had this Issue the other day.

We captured an image from an HP server, where they were using a very cheap RAID controller. I actually had two problems:

First, the image came out with a corrupted boot loader (I was able to fix this one using ISO Server 2008 Disk, repair mode, cmd line, i used bcdedit utility).

Second, after taking care of that, the server was blue-screening with "Stop error 0x0000007b". I used my ISO server 2008 R2 image again, go through the same procedure, until i got to the command prompt, ran regedit and load the hive from my Windows partition (in this case was D:). In order for me to fix it, i had to disable (0x4) some LSI-SAS services drivers that were installed in the original server and enable (0x0) my LSI-SCSI, because that is what i am using in my VM. It worked!

I hope this solution points others in the right direction.


Hi I had the same BSOD when starting a restored Acronis image which restored without error. Symptoms: Source of image: Hp ml350 g8 SAS raid Server Destination: Virtual box on Desktop PC

Windows 2008 r2 started boot process (bar progressing) As bar completed BSOD appeared 0x0000007b

My solution. Detached the VDI image from the Current controller and attached it to the IDE controller that the CD/DVD device was attached to. Now Boots Correctly

To Detatch a VDI: Stop the VM Go to Settings > Storage At the bottom of the list of storage controllers are 4 small icons, the Right most icon removes the controller( Make sure you have highlighted the controller connected to the VDI in the list above)Click to remove. The controller and VDI have now Gone. Highlight the IDE controller Now Click the Left most icon Below 'Add Attachment' Don't create a New Virtual drive, Select Existing VDI > just browse to where the VDI file is and select. Job Done. Start the VM. Obviously I can't assure you that it will work for you, but it is quick and it worked for me.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .