We have set up a XenServer, and trying to set-up a CentOS 6 guest VM.

The installation went fine (using RHEL 6 template), but I'm unable to properly configure the network. The guest VM is able to ping the host machine, but unable to ping any outside machines or gateway.

The network settings look just fine - same subnet range and valid IP.

Any idea what else I can check?



I imagine the most likely culprit is the firewall on the host. This can be confirmed by running

/etc/init.d/iptables stop

Which will stop the firewall. Then try your ping tests. Use

/etc/init.d/iptables start

To bring it back up again once confirmed.

| improve this answer | |
  • Tried this, still no luck. I see peth0 interface missing on XenServer host (it required on open-source Xen), this be the problem? – SyRenity Sep 27 '11 at 11:11
  • The name of the interface isn't too important, but you do need a bridge of some kind if they are to exist on the same network. Can you post the vif line from the config file? – Paul Sep 27 '11 at 23:21
  • Hi. I'm not sure where the config files located on XenServer, any idea where to look for them? – SyRenity Oct 20 '11 at 11:11

Just moved the machines to second NIC - and magically they started seeing the network.

Quite strange but it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.