I'm having issues with a Solaris 10 SPARC host... It seems not able to discover newly provisioned disks. The disks are fed through a QLogic 2300 FC HBA.

I've tried cfgadm -al/cfgadm -f -c configure c0 + cfgadm -f -c configure c1, devfsadm -Cv as suggested by Google results, but these commands didn't seem to work...

Does anyone know any other way for Solaris 10 to scan/rescan for newly added FC disks?

migrated from stackoverflow.com Sep 26 '11 at 21:02

This question came from our site for professional and enthusiast programmers.

  • 2
    This doesn't sound like a programming question... – Matt Ball Sep 26 '11 at 20:44
  • 1
    I think this will get better answers if migrated to unix.stackexchange.com – P.T. Sep 26 '11 at 20:48

I talked to QLogic customer support and their Level 2 engineers suggest doing

/opt/QLogic_Corporation/drvutil/qla2300/qlreconfig -d qla2300

or use their ioctl tool to perform a rescan on the HBA.

I tried both and found doing a rescan using the ioctl tool didn't work very well, but the qlreconfig always worked. What qlreconfig does is basically to unload and reload the driver HBA. Therefore, it is disruptive…

As suggested in the command path, this solution is only tested with qla2300 driver. Other QLogic HBA models may not have this issue, but I haven't got a chance to confirm that. If the directory "/opt/QLogic_Corporation" cannot be found, the system may be using the HBA driver shipped with Solaris. You would have to install the driver provided by QLogic to use the utility.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.