I have an issue with a test environment running win 2k3 SP2 and IIS6

We have a number of development sites on the box, and several versions of the same site eg:

subdomain1.domain.co.uk subdomain2.domain.co.uk subdomain3.domain.co.uk subdomain4.domain.co.uk

All sites were running fine without an issue and nothing has changed. IIS and server config for all sites match.


one of the sites (subdomain3) has just encountered an issue, It's no longer available. Browser throws an error of: The page cannot be displayed

Error Code 64: Host not available
Background: The connection to the Web server was lost. 

So, I log on to the box, edit the hosts file and try again.

Same error.

This left me scratching my head a little, so i changed the home folder to one of the other subdmains that i know is working.

Same error again

Error Code 64: Host not available
Background: The connection to the Web server was lost.

Ok time to remove the site in IIS and re-create site and app pool with the same config as the other sites running, then IIS reset and test the site locally.

Got the same error again, and again too when I change the home folder to one that I know is working.

Im at a bit of a loss as I have completely removed it's instance in IIS and re-created and tested with sites that i know are working. It's certainly not a DNS issue and don't believe it to be a coding issue either because the instance in IIS does not work with any other home folder that I know are working.

Can anyone help??


  • Why are you editing the hosts file on the server? Are you trying to access the site from the server itself? – joeqwerty Sep 29 '11 at 12:43
  • To rule out any problems with the site it's self. The site is not viewable from the local server or the net. As i have said, it really does look like IIS does not like this instance as i have re created the instance of the site in IIS and it still does not work., i have pointed the instance in IIS to a home folder of a site that i know is working fine but this also does not work. Just did it to rule out any DNS issues... – Andy Smith Sep 29 '11 at 13:29
  • Gotcha. Good troubleshooting steps. I was just making sure that you didn't think the local hosts file on the server was for name resolution for the clients accessing the web site. – joeqwerty Sep 29 '11 at 13:46

Event logs: Are there any events logged indicating app pool failures? (System log for W3ADM/W3SVC events; App log for actual W3WP-sourced events)

  • Hi Tristan. Thanks for your answer post. The issue was not connected with an app pool but did indicated a problem with an ISAPI .dll as the site was a dev site it was difficult to find the error in the event logs, though after looking again after your post, it helped me find the issue!. Cheers again buddy!!! – Andy Smith Oct 10 '11 at 10:43
  • Excellent - App Pools actually map to worker processes better than Web Sites do, so a failure to load a DLL nukes the App Pool. Glad you found it! :) – TristanK Oct 10 '11 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.