I just got a new machine, its 64 bit however I still have an application that was written in a 32 bit environment using .net 2.0. I made some changes to the code and tried to debug and I get:

HTTP Error 500.0 - Internal Server Error
Calling LoadLibraryEx on ISAPI filter

"C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_filter.dll" failed"

So I googled for the life of me and it tells me to reregister IIS. I do that several times but to no avail. I also checked the app pool for this app and it was set to use the wrong .net version (4.0). So I changed it to use 2.0. Restarted IIS tried to run the app same error message.

If I go into IIS management right click the site name select "Manage Application"->"Advanced Settings..." I have the screen shot here:

enter image description here

If I click on the application pool section it says this:

enter image description here

So I am not sure what I am doing wrong...I look inside c:\windows\microsoft.net and I have the 2 folders "Framework" and "Framework64" I assume the prior is for 32 bit:

enter image description here

Finally the last thing I look at is the "ISAPI and CGI Restrictions" within IIS Management. Here is what they are set to:

enter image description here

Again I am running on an AMD64 bit system running windows 7. I have all the various frameworks installed, however this particular app is an asp.net 2.0 application. Any help is appreciated...

closed as off topic by MDMarra, mailq, Ward, Shane Madden, Iain Dec 7 '11 at 21:05

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Why was this closed as off topic? What is so off topic about it? – JonH Jun 14 '12 at 15:09

Wow I got it working thanks to this: http://www.codertakeout.com/v/35674/4O9BY I had to enable 32 bit apps in the app pool as well as enable the ISAPI CGI Restrictions for the 32 bit version of ASP.net v2.0

All confusing stuff!

Not the answer you're looking for? Browse other questions tagged or ask your own question.